Recipient list grayed out / Send button grayed out

RESOLVED DUPLICATE of bug 881588

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 881588
4 years ago
4 years ago

People

(Reporter: bhendel, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 778857 [details]
earlybird.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.22 Safari/537.36

Steps to reproduce:

I tried replying to a message and Forwarding to a message.


Actual results:

Message compose window opens with the recipient(s) populated, but the To/CC dropdowns are grayed out, and the recipients are grayed out. Additionally, I can't add any new recipients. It's like that entire block is disabled.  Also, sometimes the send button is disabled as well.

I close the reply window, reopen, and same thing. I try CTRL-R, same thing. I open the window up in a new tab, and click reply, same thing.

Clicking Forward allows me to control the recipients, but the send button is grayed out. If I click Forward again, the send button is live. I close the window, click it again, and it opens disabled. So inconsistent behavior here. I wait 30 seconds to see if the send button enables itself but it does not.

Activity monitor shows no active connection.

Note that there is a broken image embedded in the email body, which could have an impact?

Restarting Earlybird makes everything work fine again for a while.

Windows 7 64, Earlybird 24.0a2 (2013-07-18). Connected to an SSL IMAP/SMTP server (Mailenable)


Expected results:

Reply / Forward compose windows should have their Send buttons enabled, and the recipient list not disabled.
(Reporter)

Comment 1

4 years ago
Actually, even after a restart, that particular email still won't allow editing of recipients. I clicked "Show remote content" before replying, and now the embedded image is no longer broken in the reply, but still, recipient list is disabled.

I cleared all of the body content out of the reply email, and recipient list is still disabled.
(Reporter)

Comment 2

4 years ago
Also note that my example of "Forward" having an issue (send button disabled) might be the fact that I didn't yet add a recipient! Duh. But my Reply issue still stands.

Also, it seems that I can select ANY email of my mailboxes, and the recipient list is locked, so it does not seem related to any specific email.

I restarted again, and I was able to open the message compose window normally. I closed that window (without sending) clicked on any other email, clicked reply, and not my recipient list is locked again. Same for all further emails until restart.

Comment 3

4 years ago
Can you try disabling Spell checking in Options?
(Reporter)

Comment 4

4 years ago
I ran into the issue today.  Closed the reply window and reopened a few times to ensure it was reproducible.

I went into the settings and disabled "Enable spell check as you type". Pressed OK.

I clicked reply, and now the reply window seems to be working fine, with recipient fields editable. I will keep it this way for now and see if the problem returns before I turn the spell check back on.

Is this a known bug?

Comment 5

4 years ago
Yes it is known and should already be fixed.

standard8, is the fix in the TB24 version the reporter is using?
Flags: needinfo?(mbanner)
Could you link the bug that fixed this issue?

Comment 7

4 years ago
What I meant was bug 880595.
But you may be right, there are still some problems left in bug 881588. Is this a dupe of it?

Comment 8

4 years ago
Likely. If setting mail.compose.max_recycled_windows to 0 resolves the issue, this should be a duplicate of bug 881588 (which has a patch pending already).

Comment 9

4 years ago
Another part of bug 880595 and the fix for bug 881588 just checked in for both trunk and aurora. Thus, with a bit of luck, this should be fixed in tomorrow's Earlybird nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881588
Flags: needinfo?(mbanner)
You need to log in before you can comment on or make changes to this bug.