Scrolling regression with 20/07/13 win32 nightly

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: timbugzilla, Assigned: BenWa)

Tracking

({perf})

Trunk
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Scrolling feels very choppy/slow on some sites with today's nightly win32 build.

The Neowin website is a good example, especially when the tag cloud is on screen.

I have also noticed this on some phpBB forums. 

http://en.wikipedia.org/wiki/Main_Page seems slow too.

I am running a fast desktop (i5 4670, HD7790 GPU w/ Cat 13.4) on Win8 64bit, and have D2D/DWrite/Azure all active.

Comment 1

5 years ago
I'm experiencing the same thing.

SPECS
-----
Intel Core i7 Quad 3770K @ 5.0Ghz
Sapphire HD7970 3GB OC Edition
Windows 8 Pro x64
AMD Cat 13.6b2
D2D/DWrite/Azure all active

Comment 2

5 years ago
Maybe you should check Bug 896234
(Reporter)

Comment 3

5 years ago
(In reply to Yuan Pengfei from comment #2)
> Maybe you should check Bug 896234

Yeah, it does seem worse when the page is zoomed in.

Comment 4

5 years ago
In my case removing the add-on NoSquint seems to make scrolling normal again.  Don't know if others with this problem are also using NoSquint.

Since Mozilla seems to officially sanction NoSquint to get rid of blurry graphics due to Fx now using the OS DPI I wonder if Mozilla can give the Developer a call about this issue?

https://support.mozilla.org/en-US/kb/webpages-are-large-and-blurry-after-updating

Comment 5

5 years ago
(In reply to Yuan Pengfei from comment #2)
> Maybe you should check Bug 896234

I'm only using one tab.
Component: General → Graphics
Product: Firefox → Core
(Reporter)

Comment 6

5 years ago
(In reply to Gary [:streetwolf] from comment #4)
> In my case removing the add-on NoSquint seems to make scrolling normal
> again.  Don't know if others with this problem are also using NoSquint.
> 
> Since Mozilla seems to officially sanction NoSquint to get rid of blurry
> graphics due to Fx now using the OS DPI I wonder if Mozilla can give the
> Developer a call about this issue?
> 
> https://support.mozilla.org/en-US/kb/webpages-are-large-and-blurry-after-
> updating

I tested with a fresh profile (no addons) but the problem remained. Increase page zoom a couple of notches from default and it is obvious for me.
(Reporter)

Comment 7

5 years ago
A profile of scrolling on the the http://www.neowin.net/ homepage zoomed in two increments is here:

http://people.mozilla.com/~bgirard/cleopatra/#report=5620c5d31ee459d41ab6071885a86c7eac4b62e9

When filtering to only look at jank, it seems that nearly all the time is spent rendering text runs.

Comment 8

5 years ago
I run an OS DPI of 120 so in affect my pages are zoomed.  However, I tried zooming neowin.net one click higher and sure enough I got the shaky scrolling.
(Reporter)

Comment 9

5 years ago
At default zoom I'm not seeing any jank or slow/jerky scrolling. Here's a profile for scrolling on http://www.neowin.net/ at default page zoom:

http://people.mozilla.com/~bgirard/cleopatra/#report=169dbfdd8fc6492b34037c2356f96c8772f6dcfe

None of the text run stuff seems to be in that profile.

Comment 10

5 years ago
If I set layout.css.devPixelsPerPx to 1.0 I no longer have choppy scrolling.  Of course at 120dpi chrome and content is way to small.  I discovered that to use NoSquint I have to set full zoom at 100% (instead of 80% when layout.css.devPixelsPerPx = -1.0) and text zoom I can make any percentage.  However, the minute I change full zoom +/- 100% I get choppiness.  So I don't think NoSquint is at fault here but some regression.

Comment 11

5 years ago
Created attachment 779039 [details]
archive.zip (open index.html)

As for the scroll, approximately 2 times is slow.
If no zoom, no scroll slowness.

STR
1. Open index.html (extracted from zip)
2. Zoom-In 1 tick (Ctrl++)
3. Open Web Console (Ctrl+Shift+J)
4. Paste the following code and Press Enter
//--------------------------------------------
function x_scroll(event) {
  if (x_count < 50) {
    x_count++;
    var evt = content.document.createEvent("KeyboardEvent");
    evt.initKeyEvent ("keypress", true, true, window, 
                          null, null, null, null, 
                          40, 0) 
    content.document.dispatchEvent(evt)
  } else {
    x_max--;
    content.removeEventListener("scroll", x_scroll, false);
    content.scrollTo(0,0);
    if (x_max > 0) {
      content.addEventListener("scroll", x_scroll, false);
      x_count = 0;
      x_scroll();
    } else {
      alert((new Date().getTime() - x_start)/5);
    }
  }
}

content.focus();
var x_max = 5;
var x_count = 0;
var x_start = new Date().getTime();
content.addEventListener("scroll", x_scroll, false);

x_scroll();
//--------------------------------------------

Regression window(m-i)
Godd: 2700-2800ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/b9fe5a05edd9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130718 Firefox/25.0 ID:20130718125707
Bad: 4700-4800ms
http://hg.mozilla.org/integration/mozilla-inbound/rev/bdf71cb870ac
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130718 Firefox/25.0 ID:20130718133004
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b9fe5a05edd9&tochange=bdf71cb870ac

Suspected: Bug 873378



Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.18126)
Driver Date: 11-16-2012
Driver Version: 8.970.100.7000
GPU #2 Active: false
GPU Accelerated Windows: 3/3 Direct3D 10
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Updated

5 years ago
Blocks: 873378
Status: UNCONFIRMED → NEW
tracking-firefox25: --- → ?
Ever confirmed: true

Updated

5 years ago
Keywords: perf, regression
This'll be the sLayersCached bug.
Assignee: nobody → bgirard

Comment 13

5 years ago
Err in STR of comment #11
s/3. Open Web Console (Ctrl+Shift+J)/3. Open Browser Console (Ctrl+Shift+J)/

Comment 14

5 years ago
Sorry, 
I am not confident about the regression range.(After restart OS, the results is different)

Please anybody recheck the regression range on windows8.
No longer blocks: 873378
Keywords: regression → regressionwindow-wanted

Comment 15

5 years ago
(In reply to Alice0775 White from comment #14)
> Sorry, 
> I am not confident about the regression range.(After restart OS, the results
> is different)
> 
> Please anybody recheck the regression range on windows8.

I just did a regression check on the inbounds in W8 and can confirm your regression range.  The dates are really screwed up on the folders.  A folder marked 7/20 can really be 7/16 once you look inside of it.  Don't know if this is making our findings invalid or not.

I did restart my machine after the good and the bad btw.

Comment 16

5 years ago
(In reply to Gary [:streetwolf] from comment #15)
> (In reply to Alice0775 White from comment #14)
> > Sorry, 
> > I am not confident about the regression range.(After restart OS, the results
> > is different)
> > 
> > Please anybody recheck the regression range on windows8.
> 
> I just did a regression check on the inbounds in W8 and can confirm your
> regression range.  

Thanks
Blocks: 873378
Does a fix for bug 896250 take care of this?

Comment 18

5 years ago
(In reply to Milan Sreckovic [:milan] from comment #17)
> Does a fix for bug 896250 take care of this?

Bug 896250 landed on inbound which I am running and it does appear to fix the choppy scrolling covered in this bug.  However, I see that it is going to be backed out on inbound due to an Android problem.
(Reporter)

Comment 19

5 years ago
Yeah, the inbound PGO build from changeset 90543abea431 seems to fix the scrolling problems.


http://hg.mozilla.org/integration/mozilla-inbound/rev/90543abea431
Is this still an issue given the backout which may have happened in https://bugzilla.mozilla.org/show_bug.cgi?id=896250 may have resolved this.
(needsinfo :Milan)

Can someone help try the latest build ?
Flags: needinfo?(milan)
(Reporter)

Comment 21

5 years ago
The backout seems to have fixed it. The regression is gone with today's nightly build.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(milan)
Resolution: --- → WORKSFORME

Updated

5 years ago
tracking-firefox25: ? → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.