Profiling should work in private browsing via obfuscating frames from private tabs

RESOLVED WONTFIX

Status

DevTools
Performance Tools (Profiler/Timeline)
P3
normal
RESOLVED WONTFIX
5 years ago
5 days ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

[environment]
* OSX 10.8.4
* http://hg.mozilla.org/mozilla-central/rev/bf73e10f5e54

[step to reproduce]
1. Open devtools profiler on tabs which is opened in private browsing mode.
2. Click the button to start profiling.

[Result]
* This error massage is shown in browser console
--------
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIProfiler.StartProfiler]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/actors/profiler.js :: ProfilerActor.prototype.onStartProfiler :: line 86"  data: no]
undefined @ resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js:756
--------
* each profile lists are displayed as "idle".
Priority: -- → P2
Confirmed on the trunk build running on OS X Mountain Lion.
Summary: Profiler doesn't work in private broswing mode → Profiler doesn't work in private browsing mode

Comment 2

5 years ago
This is a direct outcome of bug 822135, and actually desired behavior.

The "UI" sucks, though, as there is no UI and not even an error message. I had to figure this out by looking to the console and then into the code.

Therefore, there should either be proper UI notifying the user that the profile is disabled while there is a private browsing window active, or the profiler should be available and just dump the samples when "last-pb-context-exited" like other components do.
I'd opt for the later, or at least a way to pref this off, as I was specifically trying to profile a code path in one of my extensions that only runs in private windows.

Benoit, I guess the ball is in your corner now?
Flags: needinfo?(bgirard)
I'm ok with adding an option to force disable this safety measure but otherwise I rather just have it disable it instead of running the profiler in a crippled privacy mode without having a good way to warn the users.

I think the right fix here is to improve the UI to explain why the profiler is locked.
Flags: needinfo?(bgirard)
Duplicate of this bug: 930340
OS: Mac OS X → All
Priority: P2 → P3
Hardware: x86 → All
Duplicate of this bug: 1050378
Duplicate of this bug: 1061892
It seems that sometimes profiling works in PBM. From IRC today:

1:41 PM <Tew> past - private window, performance started (and completed) successfully, http://i.imgur.com/jHsMzQz.png
Summary: Profiler doesn't work in private browsing mode → Profiling should work in private browsing via obfuscating frames from private tabs
If we can identify frames via content window in bug 1152400, we might be able to obfuscate only specific tabs so the perftools can still function in private browsing
Depends on: 1152400
Duplicate of this bug: 1205460
Closing this bug as this is the desired behavior, and there are currently no plans to do the work to obfuscate the data.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX

Updated

5 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.