[Buri][REG][STK]call can not establish by setup call command

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [u=commsapps-user c=stk p=0][Sprint 2])

Attachments

(3 attachments)

178.01 KB, application/octet-stream
Details
13.25 KB, application/octet-stream
Details
163.22 KB, text/plain
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.158
 Firefox os  v1.1
 Mozilla build ID:20130709070206
 
 
 DEFECT DESCRIPTION:
 [REG][STK]call can not establish by setup call command
  REPRODUCING PROCEDURES:
 1.Load a simulated SIM card which can send "setup call" command;
 2.Run test case STN03002-->not busy;
 3.prompt message and NO /YES button, if click NO , return TR is :"user did not accept set-up call request";
 if click YES ,return TR is the same as click NO. ===>KO,all call can not establish by setup call command.
 
 
 
  EXPECTED BEHAVIOUR:
 call can establish by setup call command.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 779080 [details]
QXDM log
(Reporter)

Comment 3

5 years ago
Created attachment 779081 [details]
ADB log
is it possible to provide log traces with GAIA LOG mode enabled?

Settings - Device Information - More information - Developer - Gaia debug traces
Flags: needinfo?(sync-1)

Comment 5

5 years ago
Created attachment 782979 [details]
492519.txt

the user accept set up call

Comment 6

5 years ago
(In reply to Fernando R. Sela [:frsela] from comment #4)
> is it possible to provide log traces with GAIA LOG mode enabled?
> 
> Settings - Device Information - More information - Developer - Gaia debug
> traces

the log "492519.txt " with gaia enable has been added.

Updated

5 years ago
Flags: needinfo?(sync-1)

Updated

5 years ago
Whiteboard: [u=commsapps-user c=stk p=0][Sprint 2]
STK Gaia side is notifying platform side, but the modem is sending an error:

I/GeckoDump(  137): [system] sendStkResponse to command: {"commandNumber":1,"typeOfCommand":16,"commandQualifier":0,"options":{"confirmMessage":"National Number >>> 015566XXXX","address":"33155663732"}}
I/GeckoDump(  137): [system] sendStkResponse -- # response = {"hasConfirmed":true,"resultCode":0}
I/Gecko   (  137): -*- QCContentHelper_QC_B2G: receiveMessage: 'RIL:SendStkResponse' arrived from content process
I/Gecko   (  137): -*- QCContentHelper_QC_B2G: RIL:SendStkResponse -response='{"cmdDet":{"compRequired":true,"commandNumber":1,"typeOfCommand":16,"commandQualifier":0},"resultcode":0,"itemIdentifier":0,"text":null,"language":null,"ics2":false,"confirmed":true}
E/STK_QC_B2G(  137): STK_HANDLE_CALL_SETUP_REQUESTED_FROM_SIM has error response: 2

asking platform and modem guys for more info.
Flags: needinfo?(cyang)
Flags: needinfo?(allstars.chh)
Check the 492519.txt and radio log only found error 2.
Error 2 means Generic Error,
maybe Carol could check what's happening from modem.
Flags: needinfo?(allstars.chh)

Comment 9

5 years ago
Nivi, can you please take a look at this?
Flags: needinfo?(cyang) → needinfo?(nsarkar)
Any update on this? (no info from August 1st)

Comment 11

5 years ago
I am looking into it. Will send a response soon.
koi+ as it is added to comms team Sprint 3
blocking-b2g: --- → koi+

Comment 13

5 years ago
I was not able to reproduce this issue on our end. Could you please file an SR?
Flags: needinfo?(nsarkar)

Comment 14

5 years ago
Hi sync-1, we can provide support through our SR system. Please file one and provide the SR number here.
Flags: needinfo?(sync-1)

Comment 15

5 years ago
the last version has resolve this pr, please close this pr, thanks.
Flags: needinfo?(sync-1)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.