N620 Printing crashes [@ MixedMode]

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: greer, Assigned: dcone (gone))

Tracking

({crash, topcrash})

Trunk
PowerPC
Mac System 9.x
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Talkback reports show multiple users crashing while trying to print using M092 
on Mac

Mode   11
     First BBID :32384731
     Last BBID  :32529955
     Min Runtime :201
     Max Runtime :73377
     First Appearance Date : 2001-07-01
     Last Appearance Date : 2001-07-04
     First BuildID : 2001062823
     Last BuildID : 2001062823

Stack Trace:

         MixedMode + 0x224 (0xffcf0644)
         nsDeviceContextSpecMac::Init() [nsDeviceContextSpecMac.cpp  line 364]
         nsDeviceContextSpecFactoryMac::CreateDeviceContextSpec()
[nsDeviceContextSpecFactoryM.cpp  line 71]
         DocumentViewerImpl::Print()    [nsDocumentViewer.cpp  line 4375]
         GlobalWindowImpl::Print()      [nsGlobalWindow.cpp  line 1860]
         CODE.10
         XPTC_InvokeByIndex()   [xptcinvoke_mac.cpp  line 129]
         XPCWrappedNative::CallMethod() [xpcwrappednative.cpp  line 1880]
         XPC_WN_CallMethod()    [xpcwrappednativejsops.cpp  line 1252]
(32529955)   URL:
http://www.bug.co.jp/mn128/
     (32529955) Comments: Crashed as I attempted to print.
     (32498908) Comments: crashed when atempting to print.
     (32493547) URL: www.ericsson.com/t29/
     (32493547) Comments: clicking a link at above address
     (32447632) Comments: Printing  to a Postscript file.
     (32419043) URL: http://www.dowjonesnews.com
     (32419043) Comments: Crashed when I tried to print from Mozilla 0.9.2
     (32413441) Comments: Why?
     (32408564) URL: http://www.teshreen.com/syriatimes/s-sa/economy-s001.htm
     (32408564) Comments: Mozillah crashed when I tried to print.  Mozillah
0.9.2
     (32408427) Comments: Crashed when I tried to print from Mozilla 0.9.2
     (32384731) Comments: I was trying to print.
(Reporter)

Comment 1

17 years ago
Adding crash and topcrash keywords for talkback tracking
Keywords: crash, topcrash

Comment 2

17 years ago
I tried to reproduce this by going to 
http://www.teshreen.com/syriatimes/s-sa/economy-s001.htm
 and printing the page, but did not crash.

However, I went to http://www.ericsson.com/t29/ and clicked on the picture of a
cell phone on the right side of the page and crashed before the pop up window
could completely render.  For some reason, the Talkback dialog isn't popping up,
so I couldn't get a report on this crash.  Perhaps someone else can try this and
see what happens?

Comment 3

17 years ago
could this be related to 89639 ? see jpatel's comments...he clicked on an image.

Comment 4

17 years ago
I tried also using trunk on Mac 7/9 build.

1) launch netscape, jump to netscape.com, print, no problem
2) launch netscape, jump to www.ericsson.com/t29/, print, no problem
3) launch netscape, jump to www.ericsson.com/t29/, click on cellphone image
link, print, no problem

should I try all of this on branch?

we need a reprodicible test case

Comment 5

17 years ago
Using 7/9 branch on Mac, I can't reproduce a crash.

I tried several URLS...they all print fine.

Tom Greer is gonna look into this further...please include
comments in this bug report...thanks Tom!
(Reporter)

Comment 6

17 years ago
Sujay, the Trunk showed Mac crashes under this signature (6/29 & 6/30) but more 
like the crash that jpatel mentioned. Users report crashes after clicking not 
printing. Still trying to repro the print bug. I'll attach the stack and 
comments from the trunk for review. It may be a different bug.

         
(Reporter)

Comment 7

17 years ago
Created attachment 41770 [details]
Trunk stack and comments for MixedMode signature

Comment 8

17 years ago
Using today's branch build, I can't crash with the steps I mentioned last week.
 Now when I click on the phone image, The pop up opens up and a second window
also opens telling me how the plugin doesn't work with netscape 6 (i think it
was shockwave).  In any case, I can't reproduce the crash.  I also tried
printing the ericsoon page, and it worked.
(Assignee)

Comment 9

17 years ago
I will resolve this bug.. worksforme.. since I could never reproduce.. and was 
waiting for more info.  If this happens again.. please reopen and include the 
build, the printer your using, operating system version, everything you can 
think of.  It may be due to something that sounds trivial, but important in this 
case.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
I also could not reproduce....

Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

17 years ago
Leaving WFM but for thoroughness I will include some info from the latest crash 
that matches this signature. Per dcone's comments of 7/13 I dug out some deeper 
specifics about the system it crashed on. 

1 Incident   32706761  (he crashed agin later, incident 32980660) 
 
 Model  Macintosh  (0x196)
 Physical Memory   320.0 MB
 Processor  PowerPC  750 (G3)
 Processor Speed   400
 User Email Address   webmaster@jime.or.jp

        Build: 2001062823 CrashDate: 2001-07-09 UptimeMinutes: 411  Total: 669 
        OS: MacOS version 9.1
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=32706761
         StackTrace: 
http://climate/reports/stackcommentemail.cfm?dynamicBBID=32706761
     (32706761) URL: (any page)
     (32706761) Comments: Crashed when attempted to print.
(Reporter)

Comment 12

17 years ago
I emailed the primary crasher for this bug and he sent me the answers to my
questions this morning. It may be possible that we could not crash this one
because he is using a printer that is (according to his comment) only available
in Japan.
Leaving WFM.
-------
Printer:  Epson LP-8700 (seems for Japanese market only)
          This is a laser printer.
Printer command:  ESC/P, but connected in AppleTalk 
                  through its network interface and 
                  EPSON driver.
Network Printer (ethernet)
PC Hard:  Apple iMac, G4 (both early 2001 model), G3
OS:  MacOS 9.1 (for Japanese)
     (NO problem in Windows Mozilla with the above printer)

I can print to this printer from any other Macintosh software such as MS
Word, Excel, PowerPoint, Internet Explorer; Adobe PageMager, FrameMaker,
Acrobat; Claris FileMaker; Netscape Communicator.

There are many patterns.  I opened only 1 page in one occasion.  I
opened 5 - 10 pages in other occasions.

Mozillah 0.9.2 seldom crashes in navigations other than printing.

In any case, I've never been successful in printing.

The crash happens when I attempt to open the print dialog box and before
the print dialog box actually opens.  So the Mozilla crashes before I
see the print dialog box.
(Reporter)

Comment 13

17 years ago
Leaving WFM, but adding the recent user comments. I'll see if I can email a 
couple of the users for more info.
 
    (34387759) Comments: I  had asked to print out the full text of an online
article  but the extension set I was using did not include the printer
extensions.
     (34385890) Comments: mail
     (34347634) Comments: printing a web page to pdf
     (34289423) Comments: scrolling through my sent mail folder
     (34280116) Comments: I installed Acrobat 5.0 and was trying the feature to
convert to pdf files.  I tried to print the page to a pdf file and crased
twice...  just playing... but why did it crash?
     (34264761) Comments: I was trying to print my calender from the MyNetscape
page. I wanted to save it as a file so I could print it in landscape so it would
fit on one page  but as soon as I tried to save it as a file  the computer
crashed. I can't provide the URL because the
     (34264761) Comments:  page disappeared.
     (34259218) Comments: I was trying to print out my address book (s) which I
had imported from Netscape Communicator 4.76.  I can't get my printer to finish
printing out the address book last three pages.  I had just installed Netscape
Communicator 6.1 to try to retain some of
     (34259218) Comments:  my old files. 
Summary: M092 Printing crashes [@ MixedMode] → M092 N610 Printing crashes [@ MixedMode]
(Reporter)

Comment 14

17 years ago
Updating the summary to N620. Since I'm not seeing incidents on M095 ro the
Trunk I will leave this as WFM. These are the current N620 incidents with comments:

(38210197) - MacOS version 9.0: Trying to read a news post. URL:
www.lordsofpain.net/index2.html
(37997322) - MacOS version 9.2.1: choose to Print (to a PDF File  with Acrobat
5.0 installed)  Netscape  with other 4-5 
session-window open  close unexpectedly. URL: http://www.register.it
(38000235) - MacOS version 9.0.4: returning to home page URL: 
(37957756) - MacOS version 9.0:  large map being displayed) URL:
www.mapquest.com (map results
(37823929) - MacOS version 9.2.1: i had two netscape windows open with AoL IM
activated. as i started typing the URL in 
the second window  the automatic URL completer seemed to have caused the crash 
which brought down the whole system. 
(37913651) - MacOS version 8.6: Was trying to change printers using the Chooser.
URL: 
(37927278) - MacOS version 9.1: I went to my preferences to select one of them.
 The list of preferences in one of the folders looked bizarre.  It crash wright
after.  I had Microsoft Explorer open when it occurred.  
(37988788) - MacOS version 9.2.1: I intended to print a website (www.sfn.org)
into a PDF-File. Netscape didn't like this action and instantly quited. This is
a annoying one.  
(38235134) - MacOS version 9.2.1: printing an email message 
Summary: M092 N610 Printing crashes [@ MixedMode] → N620 Printing crashes [@ MixedMode]
Crash Signature: [@ MixedMode]
You need to log in before you can comment on or make changes to this bug.