Closed Bug 896368 Opened 9 years ago Closed 9 years ago

Follow up to bug882593 [SMS/MMS] When tapping on a contact added into 'To' field, the picture is not shown

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 924475

People

(Reporter: isabelrios, Assigned: kt.at.kitamura)

References

Details

(Whiteboard: MMS_TEF)

Attachments

(1 file)

Unagi device v1-train 07/21 build:
Gecko-1fc50aa
Gaia-c4bdd32
ref ril

STR
1. Open Messaging app and create a message
2. Select a contact with picture to add into 'To' field
3. Once added, tap on it.

EXPECTED
According to latest doc: HTML5_SMS-MMSUserStorySpecifications_20130503_V8.0, on pag#16 -> Step 5., on the contact details view, the picture should also be shown.

ACTUAL
Contact info is shown ok but the picture is missing.

Marking as leo? as it is a follow up of a leo+ bug.
Assignee: nobody → fernando.campo
Whiteboard: MMS_TEF → MMS_TEF, [u=commsapps-user c=messaging p=0]
After speaking with Borja and checking open bugs, we found a clash with bug 882154, where the new visuals for the prompt shows no image for the contact. I'm blocking this till it's resolved and comment in the other bug
Depends on: 882154
Not clear why this should be a blocker at this late point in the release. We can always fix in 1.2.
blocking-b2g: leo? → -
Victoria, for adding this feature we need your help here! Visual specs does not include the picture (check https://bug882154.bugzilla.mozilla.org/attachment.cgi?id=767098 ), so probably we need to update this for adding this info.
Flags: needinfo?(vpg)
Visual specs attached.
Flags: needinfo?(vpg)
blocking-b2g: - → koi?
Whiteboard: MMS_TEF, [u=commsapps-user c=messaging p=0] → MMS_TEF,
see bug 873498: Victoria actually asked us to remove the picture at one point.
Hi Julien, 
There seems to be a confusion here, they are different cases. The bug 873498 talks about the contacts suggestions when composing an SMS, which should be a very light, fast "autocomplete" kind of situation, while this is the Contacts information overlay. Even though I don't buy completley the idea of pictures in overlays, for the sake of consistency, and after designing other screens where contact information is crucial, like merging contacts, where we used photos in order to help recognize duplicates, the picture would be valid.

Sorry for the confusion, let's have the photo.

Thanks! Victoria

(In reply to Julien Wajsberg [:julienw] from comment #5)
> see bug 873498: Victoria actually asked us to remove the picture at one
> point.
oki, I get it, and now it's clearer :)

thanks all!
add to backlog 891754
blocking-b2g: koi? → ---
Fernando, I'm removing you as assignee here, but feel free to assign back if you think you can work on this.

This is a moderately difficult good first bug.
Assignee: fernando.campo → nobody
Whiteboard: MMS_TEF, → MMS_TEF, [good-first-bug][mentor=:julienw]
Hi Julien-san,

I try this bug with Kobayashi-san.
This bug is going to be able to advance with bug 890209.
Please assign to me.
Assignee: nobody → at-kitamura
Hi Kitamura-san, 

I'll dupe this bug to bug 924475, because there is more work needed in this panel, and I'd like that only one person work on this.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924475
Whiteboard: MMS_TEF, [good-first-bug][mentor=:julienw] → MMS_TEF
You need to log in before you can comment on or make changes to this bug.