Context menu doesn't appear when right clicking on a tab that is "over" a plugin (OS X)

VERIFIED FIXED in Firefox 32

Status

()

Core
Widget
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: Michael Boon, Assigned: smichaud)

Tracking

Trunk
mozilla32
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox32 verified)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

- Open a webpage with a decent sized flash player. (e.g. Youtube)
- Right click on a tab or something on the bookmarks toolbar and you'll see it works normally
- Scroll the page down so that a bookmark or tab is "over" the video and try again. You'll see that nothing happens when you right click it


Actual results:

No context menu


Expected results:

Context menu
I can reproduce this, but inconsistently.
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
(Assignee)

Comment 2

4 years ago
I can reproduce this consistently, though so far I've only tested in FF 22 on OS X 10.8.4.  You don't need to make the Bookmarks toolbar visible -- the problem also happens with the regular "tab bar".

Here's STR:

1) Visit http://mirrors.creativecommons.org/reticulum_rex/ in a "normal" sized window.
2) Right-click on the "Reticulum Rex" tab -- you'll see a context menu.
3) Resize the window so that it's much smaller, then scroll down until the Flash "movie" is partly "under" the tab.
4) Right-click again on the "Reticulum Rex" tab -- nothing happens.
(Assignee)

Comment 3

4 years ago
This bug also happens using my Debug Events Plugin from bug 441880.  So it has nothing to do with Flash, and is probably our fault.

I'll look for a regression range.
(Assignee)

Updated

4 years ago
Summary: Context menu doesn't appear when right clicking on a tab or bookmark that is "over" flash (OS X) → Context menu doesn't appear when right clicking on a tab that is "over" a plugin (OS X)
(Assignee)

Comment 4

4 years ago
This doesn't happen on Windows (XP or 7), so it really does seem to be Mac-specific.
(Assignee)

Comment 5

4 years ago
This is a *very* old bug, at least on OS X 10.8 and 10.7 -- I see it back to FF 4.0.1!

I wonder if it's been noticed before.
(Assignee)

Comment 6

4 years ago
This bug also happens (back at least to FF 4.0.1) on OS X 10.6.8.

Especially considering how old it is, I don't consider this bug very urgent.  So I wonder when/if I'll be able to justify spending time on it.
(Assignee)

Updated

4 years ago
Component: Widget: Cocoa → Plug-ins
Hardware: x86 → All
Version: 22 Branch → unspecified
Steven, might it be a good first bug for someone, or a bug you'd be willing to mentor?
Flags: needinfo?(smichaud)

Comment 8

4 years ago
This is definitely not a "good first bug" in our standard definition in that it will require some significant debugging skill. But I do think that if we have a volunteer who knows mac event debugging, we can find an appropriate mentor!
Whiteboard: [mentor=benjamin@smedbergs.us]
(Assignee)

Comment 9

4 years ago
What we need is someone willing and able to trace events from where the OS delivers them to us (in -[ChildView mouseDown:] and -[ChildView rightMouseDown:] in nsChildView.mm), up into Gecko, and from there to a plugin.

The ability to trace this whole path is definitely *not* a beginning-level debugging skill, even for many Mozilla employees.  For example I could do it, but it'd still take me several hours of work (even though I've done something similar several times before).

However, there's some reason to hope that the problem (our bug) lies close to the beginning of this path (in Cocoa widget code).  So to start with we just need to find someone willing and able to trace events from where they enter Cocoa widget code until just before they get sent to Gecko.

Once you find this person, I'd be willing to work with him or her :-)

(By the way, I suspect the root cause of this bug is that the OS is delivering events to the plugin's ChildView/NSView that don't "belong" to the plugin.)
Flags: needinfo?(smichaud)
This was fixed by bug 995603.
https://hg.mozilla.org/mozilla-central/rev/b850412044d7
Assignee: nobody → smichaud
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Plug-ins → Widget
Depends on: 995603
Resolution: --- → FIXED
Whiteboard: [mentor=benjamin@smedbergs.us]
Target Milestone: --- → mozilla32
Version: unspecified → Trunk
Keywords: verifyme
Reproduced the bug on Nightly 2014-04-30. 

Verified fixed on Mac OSX 10.8.5 using Firefox 32 Beta 8 (buildID: 20140818191513).
Status: RESOLVED → VERIFIED
status-firefox32: --- → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.