Closed Bug 896564 Opened 9 years ago Closed 9 years ago

[dev][stage] /user/edit/ Adding new accounts does not work properly

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mbrandt, Unassigned)

References

()

Details

(Whiteboard: [dev][stage])

Adding accounts to a user profile does not appear to work (dev and stage); github, bugzilla, etc.

* helper text in form field is always for github
* helper text should be removed from the form field when a user selects it, they should not be re
* creating/saving accounts does not work. account name is not saved
* once an account is created the username field should /not/ be editable
* accounts do not show up on the user's profile page /u/ once saved.

Steps to reproduce:
0. goto https://mozillians.allizom.org/user/edit/
1. add several accounts
2. save profile

Actual:
* feature does not appear to work - http://screencast.com/t/0OlXouZmw2hP

Expected:
A user can add external accounts to their Mozillians profile
I think this functionality has not been implemented on the back-end code yet, so I am going to set this as dependent on bug 881852.

Here's the Expected Result, in addition to comment 0:
* Helper text in form field should change as different types of accounts are selected
* Helper text should be removed from the form field when a user is focused on that field
* Accounts should be saved when a profile is edited
* Once an account is created the username field should /not/ be editable
* Accounts should be visible on the user's profile page /u/ once saved
Depends on: 881852
As with 881852 (which some might argue this bug is a dupe of), this bug will be resolved by a future release.
Target Milestone: 2013-07-25 → ---
I think this bug is resolved (with bug 881852). Please reopen if I'm wrong!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You are correct, this has been resolved! thank you
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.