Pasting into firefox, especially from emacs, often doesn't work

NEW
Unassigned

Status

()

Firefox
General
5 years ago
2 years ago

People

(Reporter: sfink, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Firefox ate my longer description of this bug when I attempted to paste a chunk of text -- see https://crash-stats.mozilla.com/report/index/4d74bbb4-5fd8-4021-ab37-ddf582130722
 -- but this bug report is because I cannot paste from an emacs buffer on Fedora 18 into Firefox. But the exact behavior is variable -- sometimes I can paste from other apps, sometimes not. (eg cutting & pasting with the mouse from standalone -> Firefox was not working when I started writing this comment, then later was working.)

It doesn't seem to be just a matter of the primary selection vs the clipboard working, since if I go through xclip, both work.

That's my current workaround: select text in emacs, run xclip in a terminal, paste into the terminal, Ctrl-D, paste into firefox. That has worked every time so far, except when it triggered the above crash.

Anecdotally, catlee on irc mentioned that pasting is broken for him too.

I thought I had fixed it by upgrading Nightly, but the problem comes and goes.

Comment 1

2 years ago
I see this too. Firefox's X primary selection handling is very flaky and sporadic, and the problem is worst between firefox and emacs. I see it more often in the other direction: doubleclick in the urlbar, go to an xterm or emacs, middlemouse, oops, pasted the wrong thing, go back to firefox, doubleclick in the urlbar again, go to xterm/emacs and this time it works. I have seen flakiness in the direction you describe as well. Unfortunately I haven't found any way to reproduce it reliably or figured out what's different when it does or doesn't work.
You need to log in before you can comment on or make changes to this bug.