bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Helix] Unable to connect to Wifi After doing a reset phone

RESOLVED WORKSFORME

Status

Firefox OS
Wifi
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: swaroopa, Assigned: vchang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 779366 [details]
Wifilog_OnReset_log.txt

Base Image date: 0715

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/0e7c1dff9722
Gaia   03280104b9528b74fe2ce6b2987bb5530392fdaa
BuildID 20130722070208
Version 18.0

STR:

1. Goto settings > Device Information > More Information
2. Click on Reset Phone to do a reset.
3. Wait till the phone reboots after reset
4. Goto Settings > Wifi and try to connect to a Wifi network.

Expected Behavior:
Should be able to connect to the Wifi Successfully.

Actual Behavior:
Unable to connect to a network. 
In wifi settings, while connecting to a network observe the connection status. Status changes from Connecting.. > Getting IP address > Connected > Connection failed > Offline > Open

Updated

5 years ago
Component: Gaia → Wifi
William can you confirm this bug in Taipei?

Vincent can you please check this bug with William if it's reproduced?
blocking-b2g: hd? → hd+
Flags: needinfo?(whsu)
Flags: needinfo?(vchang)

Comment 2

5 years ago
Hi, Swaroopa,

Could I confirm your reproduce steps?
The step 4 you mentioned, "Goto Settings > Wifi and try to connect to a Wifi network."
In this step, do you mean the FxOS always stay on "Searching" status or you cannot connect to a specific WIFI network?



Hi, Wayne, Vincent, and all,

I used PVT V1.1.0 HD-20130725070202 to reproduce this case.
I cannot reproduce this bug with steps that Swaroopa attached.
But I sometimes encountered that WIFI stay on "Searching" status.
Attaching the logs.
By the way, QA's RAT test will run on WIFI module today. Maybe we can dig the related information.
Flags: needinfo?(whsu)

Comment 3

5 years ago
Created attachment 782413 [details]
[Helix] Always stay on "Searching" status

Comment 4

5 years ago
Hi, Swaroopa,

Sorry. Please skip my question above.
I got your point.
William, is this a confirmed bug?

Ken, Can you have someone check this? William's finding.
Flags: needinfo?(kchang)
(Assignee)

Updated

5 years ago
Assignee: nobody → vchang
Flags: needinfo?(vchang)

Comment 6

5 years ago
Hi, Swaroopa,

I cannot reproduce this bug with following build.
* Base Image: 20130729
* Moz PVT build: Mozilla-b2g18_v1_1_0_hd-helix/2013-07-30-23-02-01

This bug might related to firmware version.
Could you please try to test it on a newer image?
Thanks for your help!
Flags: needinfo?(kchang)

Updated

5 years ago
Flags: needinfo?(svantipalli)
(Reporter)

Comment 7

5 years ago
Yes looks like with the new base image this issue is resolved.
I am able to connect to wifi after doing reset. 
Below is the build tested:

Base Image: 0729
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f0e9fcb591c2
Gaia   1788602b9e6bfdd6c91f46e1d72b0ed134e05b41
BuildID 20130805072202
Version 18.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(svantipalli)
Resolution: --- → WORKSFORME

Comment 8

5 years ago
Hi, Swaroopa,

Thanks for your prompt help.
If you still have further concern, please feel free to contact us.
Thanks! Have a nice day!
You need to log in before you can comment on or make changes to this bug.