Closed Bug 896729 Opened 7 years ago Closed 7 years ago

Attempt to re-register network link service crashes nsComponentManager

Categories

(Core :: XPCOM, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: tatiana, Assigned: tatiana)

Details

(Keywords: crash, Whiteboard: [startupcrash])

Crash Data

Attachments

(2 files)

Attached file backtrace
Qt Firefox crashes at startup, see backtrace.
It's Ubuntu desktop.
Duplicate of bug 881237?
Severity: normal → critical
Crash Signature: [@ SafeMutex::AssertNotCurrentThreadOwns()]
Component: Widget: Qt → XPCOM
Keywords: crash
Whiteboard: [startupcrash]
(In reply to Scoobidiver from comment #2)
> Duplicate of bug 881237?

Not exactly. It crashes because LogMessage is called from the lock as explained by Benjamin in bug 881237 comment 5, but I doubt the guilty CID is the same.
Here it is 75a500a2-0030-40f7-86f8-63f225b940ae.
First time it was hardcoded here http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/netwerk/build/nsNetCID.h&rev=1.72&mark=816#816
Then here http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/system/dbus/nsDBusModule.cpp&rev=1.1&mark=50#50

@roc: NS_DBUS_NETWORK_LINK_SERVICE_CID is identical with NS_NETWORK_LINK_SERVICE_CID. Are they meant to be the same?
Typically different implementations of a service should have the same contractID and different CIDs. It seems that necko uses the same CID for all of its network link service implementations, and it happens that in the QT build we are registering both:

nsQtNetworkLinkServiceConstructor and the DBUS nsNetworkManagerListenerConstructor.

Are we really supposed to be building both of these? Which one is the "actual" network link service?

We should also randomize the CIDs, I think.
Summary: crash [@ nsComponentManagerImpl::RegisterCIDEntryLocked] → Attempt to re-register network link service crashes nsComponentManager
Attached patch patchSplinter Review
DBus network link service is no longer in use since Bug 586836. No reason to build it.
Attachment #781581 - Flags: review?(ted)
Attachment #781581 - Flags: feedback?(romaxa)
Attachment #781581 - Flags: feedback?(benjamin)
Attachment #781581 - Flags: feedback?(romaxa) → feedback+
Attachment #781581 - Flags: review?(ted)
Attachment #781581 - Flags: review+
Attachment #781581 - Flags: feedback?(benjamin)
Attachment #781581 - Flags: checkin?
Keywords: checkin-needed
Attachment #781581 - Flags: checkin? → checkin+
https://hg.mozilla.org/mozilla-central/rev/7cd08e2beee1
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.