Padding between URL Bar and Bookmarks Toolbar with Australis

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Theme
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Žilvinas, Assigned: Gijs)

Tracking

unspecified
Firefox 28
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P4][Australis:M9])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 779451 [details]
Screenshot.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1568.2 Safari/537.36

Steps to reproduce:

Enabled Bookmarks toolbar.


Actual results:

It appeared with bad padding between url bar and bookmarks toolbar.


Expected results:

Should have seen proper padding between URL Bar and Bookmarks Toolbar. I believe the problem wouldn't exist if one would still have ability to "Use Small Icons" for Toolbar. I believe all of that side effects is caused by Back button.
Stephen, this isn't covered in the spec. How much space should there be between the two toolbars?
Blocks: 870032
Component: Untriaged → Theme
Flags: needinfo?(shorlander)
Summary: Padding between URL Bar and Bookmarks Toolbar → Padding between URL Bar and Bookmarks Toolbar with Australis
Whiteboard: [Australis:P4]
Version: 25 Branch → unspecified
Created attachment 794264 [details]
Bookmarks Bar Padding - i01

Should have 6px top and bottom padding.
Flags: needinfo?(shorlander)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

4 years ago
Created attachment 821798 [details] [diff] [review]
fix bookmarks' vertical centering,

This patch depends on bug 930045's patch. Stephen and I agreed over IRC to use a 4px total padding on each side, to ensure the bookmarks' toolbar looks centered. This patch does that.
Attachment #821798 - Flags: review?(mdeboer)
(Assignee)

Updated

4 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 821798 [details] [diff] [review]
fix bookmarks' vertical centering,

Review of attachment 821798 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! Beware that this patch has bitrot.
Attachment #821798 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 5

4 years ago
https://hg.mozilla.org/projects/ux/rev/0cb33b13e2ca
Whiteboard: [Australis:P4] → [Australis:P4][Australis:M9][fixed-in-ux]
(Assignee)

Comment 37

4 years ago
https://hg.mozilla.org/mozilla-central/rev/0cb33b13e2ca
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][Australis:M9][fixed-in-ux] → [Australis:P4][Australis:M9]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.