Browser Pairs Game (from Market) does not pan correctly when trying to play the game

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: jeremykimleo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, firefox26 unaffected, b2g18 fixed, b2g18-v1.0.0 unaffected, b2g18-v1.0.1 unaffected, b2g-v1.1hd unaffected)

Details

(Whiteboard: [POVB][leo])

1. flash build v08m 
2. go to marketplace
3. install Browser Pairs game
4. launch Browser Pairs Game
5. wait for it to load, pan to the start button and press start
6. pan around

Expected: you can pan around and see different "cards"
Actual: a graphic defect of a black overlay blocking the "cards"

Note: 
1. this bug does not occur on unagi
2. this bug does not occur on mozilla version of leo
A video would help here btw.
I believe that this might be a gecko issue?  I think we would need to track down the fix.

The bug is apparent when seen.
Video : http://www.youtube.com/watch?v=Z5Gl4kRzVjw&feature=youtube_gdata_player

Again, this does not occur on Moz Gecko/Gaia.  It occurs on v08m.
That looks really bad. Leo is probably missing or has a regressing patch in their build in relation to graphics layers component.
blocking-b2g: --- → leo?
Naoki, is this the only game that we are seeing the issue with or are there any other scenario's that you may have hit this ? you mention this does not happen on mozilla version of leo, does that mean it happen's our existing 1.1 nighties ? CAn you give more build details here ?

Also can you mark this as a regression if it one ?
bajaj, I believe that jsmith's analysis is correct. It's likely that they are missing a patch or a backout or something along those lines in the graphics layer.

This isn't about one game.  It's how they handle the layers and scrolling.  

When I state that it does not occur on the mozilla version of leo, I mean it does not happen on 1.2, nor 1.1 of mozilla's builds.  This is with v08m of the Leo build.  I'm not sure exactly what you're looking for.  These details should be enough to understand which build from the leo side.  They have the information.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #6)
> bajaj, I believe that jsmith's analysis is correct. It's likely that they
> are missing a patch or a backout or something along those lines in the
> graphics layer.
> 
> This isn't about one game.  It's how they handle the layers and scrolling.  

I got that, but I did not see a comment confirming that, which was why I wanted to cross-check.
> 
> When I state that it does not occur on the mozilla version of leo, I mean it
> does not happen on 1.2, nor 1.1 of mozilla's builds.  This is with v08m of
> the Leo build.  I'm not sure exactly what you're looking for.
The above info you stated is what I was looking for exactly, just mentioning v08m is not too descriptive enough, and even jhammick was not sure what it meant in triage and hence asked for further clarification here.
>  These details
> should be enough to understand which build from the leo side.  They have the
> information.

T
completing my above comment :Thanks Naoki, for adding the details !

Needinfo'ing Leo given comment 4 here and to make sure this issue is on their radar.

Updated

4 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Flags: needinfo?(jaeohkim83)

Updated

4 years ago
Flags: needinfo?(jaeohkim83) → needinfo?(leo.bugzilla.gecko)

Comment 9

4 years ago
The information was notified with gecko team.
Flags: needinfo?(leo.bugzilla.gaia)
Triage - leo+. 

Partner is checking their build.
Assignee: nobody → jeremy.kim.leo
blocking-b2g: leo? → leo+
(Assignee)

Comment 11

4 years ago
ok, i got it

i founds some patch is missing.
http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=38e6b257a832fbd6c91fac54bf8a8c5d3572e3fb
http://git.mozilla.org/?p=releases/gecko.git;a=commit;h=e7aa9400a701c9c364e0318a028fadd3c9d3798f

Comment 12

4 years ago
jeremy handles this.
Flags: needinfo?(leo.bugzilla.gecko)
(Assignee)

Comment 13

4 years ago
released new version with missing patch.
check leo's new version for this.
QA Wanted for retest with a base image 8/2/2013 or later per comment 13.
Keywords: qawanted

Comment 15

4 years ago
have tested it today:
- build v08m  - the issue reproduces
- build v08o  - the issue does not reproduce

so, looks like it's been fixed!
Keywords: qawanted

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Resolution: WORKSFORME → FIXED
Verified.

Build v08o does work, thanks jeremy.
Status: RESOLVED → VERIFIED
Is there anything which needs to be uplifted in Gaia, or can we mark this as resolved on branch?
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #17)
> Is there anything which needs to be uplifted in Gaia, or can we mark this as
> resolved on branch?

Nope - we can mark this resolved on b2g18.
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → unaffected
status-b2g18-v1.0.1: --- → unaffected
status-b2g-v1.1hd: --- → unaffected
status-firefox26: --- → unaffected
You need to log in before you can comment on or make changes to this bug.