[B2G] [Performance User Story]: Browser App First Time Launch Latency

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: skamat, Unassigned)

Tracking

({perf, productwanted})

unspecified
ARM
Gonk (Firefox OS)
perf, productwanted

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [c=progress p= s=2013.09.20 u=])

(Reporter)

Description

5 years ago
Based on partner expectations, First time launch latency for Browser app is 1500ms. The bug is to track the user story for both (1.0.1, 1.1) releases. 1.1 should cause no regression from 1.0.1.
Whiteboard: PERF → PERF [UCID:Perf3, FT:Perf, KOI:P1]
Blocks: 897222

Updated

5 years ago
Keywords: perf

Updated

5 years ago
Whiteboard: PERF [UCID:Perf3, FT:Perf, KOI:P1] → PERF [UCID:Perf3, FT:Perf, KOI:P1] [c= u=1.2]

Updated

5 years ago
QA Contact: gmealer
Keywords: productwanted

Updated

5 years ago
blocking-b2g: --- → koi+
The startup time seems to be under 1500ms now, though I'm not sure which devices this is supposed to apply to. Can we close this bug now, or do we have to wait until 1.1 is released?
Flags: needinfo?(skamat)
Why does the startup time for 1.0.1 and 1.1 block the 1.2 release?
Flags: needinfo?(khuey)
Flags: needinfo?(khuey) → needinfo?(khu)

Comment 3

5 years ago
I saw this bug has "koi:p1" in the whiteboard. It means this is a must have item for v1.2. That's why I marked it as koi+. I assume the codes will be in v1.2 as well, isn't it? If this is not a must have for v1.2, please feel free to remove koi+.
Flags: needinfo?(khu)
(Reporter)

Comment 4

5 years ago
(In reply to Ben Francis [:benfrancis] from comment #1)
> The startup time seems to be under 1500ms now, though I'm not sure which
> devices this is supposed to apply to. Can we close this bug now, or do we
> have to wait until 1.1 is released?

Hi Ben, This is for all 7227 based devices launched in 1.0.1 and launching with 1.1. If we can test with ZTE/TCL devices w/ latest 1.1 release that should be enough to close this out now.
Flags: needinfo?(skamat)
Whiteboard: PERF [UCID:Perf3, FT:Perf, KOI:P1] [c= u=1.2] → [c= u=1.2]
Closing the old user story bugs in favor of the bugs that show the regressions based on partner testing, bug 915064 and bug 915068.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Whiteboard: [c= u=1.2] → [c=progress p= s=2013.09.20 u=]
You need to log in before you can comment on or make changes to this bug.