Closed Bug 896848 Opened 7 years ago Closed 6 years ago

[Buri][Call]The Usage app is launch automatically when receive a call

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect, P1)

defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed
b2g-v1.2 --- fixed

People

(Reporter: sync-1, Assigned: salva)

References

Details

(Whiteboard: [LeoVB+])

Attachments

(4 files)

Created an attachment (id=466691)
 PIC
 AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.164
 Firefox os  v1.1
 Mozilla build ID:20130715070218
 
 DEFECT DESCRIPTION:
  The Usage app is launch automatically when receive a call
  REPRODUCING PROCEDURES:
  Prerequisites:Long press homekey,there is noting.
  1.Receive an incoming call
  2.Connect the call,then end the call
  3.Long press home key,find Usage app is launch automatically->KO1
  4.Press the Usage app,the screen turn white->KO2
  EXPECTED BEHAVIOUR:
  The Usage app should not appear when longpress homekey
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Mid
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached image PIC
Clone from brother
Attached file Logcat
blocking-b2g: --- → leo?
Hi Salva,

Please review the attached patch.
Attachment #779725 - Flags: review?(salva)
Comment on attachment 779725 [details]
Pointer to Pull:https://github.com/mozilla-b2g/gaia/pull/11120

Clean fix.
Thank you Sireesha!
Attachment #779725 - Attachment is patch: false
Attachment #779725 - Flags: review?(salva) → review+
Master: 95cf971a1e0d1c0813279bd91200499ae706f761
Assignee: nobody → leo.bugzilla.gaia
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 826530
We decided in triage to determine if this is a regression.
QA Contact: nkot
This issue has been reported multiple times for different devices starting from 10/2012, please see: bug 798712, bug 826530, and bug 876842.

This is not a regression then.

Retested on v1.0.1 - the issue reproduces
Build ID: 20130717070202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 054cdc27404e2daca91d3065d9783681032b2151
Platform Version: 18.0
Step 3 in comment 0 isn't a common user action - this will be fixed for the first time in 1.2.
blocking-b2g: leo? → -
Duplicate of this bug: 876842
This issue is a big impact for our customers, renominating to leo+.

Ni to Salva, please clarify the risk of taken this patch.
Flags: needinfo?(salva)
The patch is *very low* risk as it only contemplates another 'auto close case'.
Flags: needinfo?(salva)
Whiteboard: [LeoVB+]
Hello, because this is very low risk, please add to leo.
Hello Salva, 
I test with your patch, after receive an incoming call and end it. Long press home key, still find usage in cardview, but can not select it.
Dear mozilla, reopen it because the problem not resolved completely. Please find in comment #16.
Status: RESOLVED → REOPENED
blocking-b2g: - → leo?
Resolution: FIXED → ---
(In reply to sync-1 from comment #16)
> Hello Salva, 
> I test with your patch, after receive an incoming call and end it. Long
> press home key, still find usage in cardview, but can not select it.

You can not select it or you can but it is in blank?
Flags: needinfo?(sync-1)
Problem located. Cooking the PR.
Assignee: leo.bugzilla.gaia → salva
Flags: needinfo?(sync-1)
Attachment #792164 - Flags: review?(francisco.jordano)
Comment on attachment 792164 [details]
Adding a missed ICCHelper

Thx Salva!
Attachment #792164 - Flags: review?(francisco.jordano) → review+
Hello Salva,
 
 I verify it in this version, it is ok. 
 You need not add icc_helper.js, because this file is not exist in v1-train.
 
 Firefox os  v1.1
 Mozilla build ID:20130812041203
Master: f7764053863baef795ee1a3b3a3f9b13b50c52b7

Cancelling leo? request as it is not necessary for v1.1.
Status: REOPENED → RESOLVED
blocking-b2g: leo? → ---
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
(In reply to sync-1 from comment #22)
> Hello Salva,
>  
>  I verify it in this version, it is ok. 
>  You need not add icc_helper.js, because this file is not exist in v1-train.
>  
>  Firefox os  v1.1
>  Mozilla build ID:20130812041203

Please renominate to leo+ if you can reproduce it in v1-train.
Blocking a blocker. Asking for leo.
Blocks: 916056
blocking-b2g: --- → leo?
blocking+ per comment 25
blocking-b2g: leo? → leo+
Uplifted f7764053863baef795ee1a3b3a3f9b13b50c52b7 to:
v1-train: 6798a7fd8fbc6f154a38e3971ed278d0a05dfb40
This uplift broke the build because it's referring to a file that doesn't exist on v1-train.

[v1-train 566d6ce] Revert "Merge pull request #11606 from lodr/bug-896848-missing-icchelper"
Flags: needinfo?(salva)
Please, see my comments on bug 916056.
Flags: needinfo?(salva)
Seems bug 916056 is not caused by this although v1-train still leaks of this patch and it will suffer similar problems. I'm going to remove the blocker and provide a "v1-train only" patch for this. Ok, John?
No longer blocks: 916056
Flags: needinfo?(jhford)
v1.1.0hd: 6798a7fd8fbc6f154a38e3971ed278d0a05dfb40
I believe providing a v1-train specific patch on the same bug is fine as long as the patch is reviewed and the flag is set correctly when patch lands.
Flags: needinfo?(jhford)
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #27)
> Uplifted f7764053863baef795ee1a3b3a3f9b13b50c52b7 to:

This is fix is split into two patches:
95cf971a1e0d1c0813279bd91200499ae706f761 <-- always needed
f7764053863baef795ee1a3b3a3f9b13b50c52b7 <-- not needed in v1-train

So, the proper commit to uplift is 95cf971a1e0d1c0813279bd91200499ae706f761
Flags: needinfo?(jhford)
Uplifted 95cf971a1e0d1c0813279bd91200499ae706f761 to:
v1-train: ff474390146bb8a5b0cce783f8036995fba9fb85
v1.2 already had this commit
v1.1.0hd: ff474390146bb8a5b0cce783f8036995fba9fb85
Flags: needinfo?(jhford)
You need to log in before you can comment on or make changes to this bug.