Cannot File/Quit if all Netscape 6 windows are closed; menus and shortcuts also broken

VERIFIED FIXED

Status

SeaMonkey
UI Design
--
critical
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Grace Bush, Assigned: Paul Chen)

Tracking

({pp, regression})

Trunk
PowerPC
Mac System 9.x
pp, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Tested on all Mac OS 8.6-9.1
Run Netscape 6 branch build 2001070603
Close all windows in upper left corner
Go to File/Quit

Nothing there but 'about balloon help' and 'show balloons'

Comment 1

17 years ago
(picking macos 9.x to indicate that this isn't a Linux PPC bug)
Assignee: asa → pinkerton
Component: Browser-General → XP Apps
OS: All → Mac System 9.x
QA Contact: doronr → sairuh
Whiteboard: DUPEME
ugh, badness --also see this in the later respin: 2001.07.06.12-branch comm.
moreover, when i close all windows, i cannot dropdown any of the menus [except
for File, which displays the brief Help menu grace described above], none of the
keyboard shortcuts work either.

anyone have any ideas what happened? to say the least, this needs to be fixed
soon.

i don't have a recent trunk build handy --anyone perchance see this on the
trunk?
Severity: normal → critical
Keywords: nsBranch, regression
...couldn't find an existing bug for this after some querying...
Summary: Cannot File/Quit if all Netscape 6 windows are closed → Cannot File/Quit if all Netscape 6 windows are closed; menus and shortcuts also broken
wfm with 7/2 branch. someone just did something with the hidden window, perhaps 
they messed it up
Assignee: pinkerton → pchen

Comment 5

17 years ago
Using Mac OS 9.1 on branch build 2001070903
Close all windows in upper left corner and go to File/Quit
Nothing there but 'Help' on taskbar

Note: I did reproduce what Grace saw on the 7/6 branch build (nothing there but 
'about balloon help' and 'show balloons' as well.  

Comment 6

17 years ago
This is not good.  Marking PDT+.
Whiteboard: DUPEME → [PDT+]DUPEME
(Assignee)

Comment 7

17 years ago
I'm in the process of updating by branch tree, will look into this as soon as
possible.

Comment 8

17 years ago
this seems like a likely culprit:

XML Error in file 'chrome://global/content/hiddenWindow.xul', 
Line Number: 47, 
Col Number: 1, 
Description: undefined entity

Source Line: %mainWindowDTD;

Comment 9

17 years ago
Created attachment 41664 [details] [diff] [review]
hidenWindow.xul patch

Comment 10

17 years ago
Patch fixes a copy/paste error.

Comment 11

17 years ago
sr=blake
(Assignee)

Comment 12

17 years ago
Well, as soon as my branch build is done, and I find the problem, Simon has gone 
off and posted a patch. ;-)

r=pchen
Whiteboard: [PDT+]DUPEME → [PDT+]DUPME, fix in had, have r= and sr=

Comment 13

17 years ago
Thanks for the teamwork and quick turnaround!
Whiteboard: [PDT+]DUPME, fix in had, have r= and sr= → [PDT+]DUPEME
(Assignee)

Comment 14

17 years ago
fix checked into branch
(Assignee)

Comment 15

17 years ago
Oooops, forgot to mark this as fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Keywords: pp
Whiteboard: [PDT+]DUPEME → [PDT+]
vrfy fixed using 2001.07.10.03-branch comm bits on Mac.
Status: RESOLVED → VERIFIED

Comment 17

17 years ago
*** Bug 90041 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.