,"") open home page instead of blank page




DOM: Core & HTML
17 years ago
15 years ago


(Reporter: Jesse Ruderman, Assigned: jst)




Firefox Tracking Flags

(Not tracked)




17 years ago
The following two bookmarklets should open a new blank window (like
about:blank), but instead they open my home page.""); void 0; void 0

If I specify about:blank, they work fine.

I think this regressed at the same time as bug 89345, but 89345 is now marked as
fixed and this bug remains.

Comment 1

17 years ago
wfm 2001070604 win98""); void 0; void 0
Both open a blank page""); open slashdot correctly

so I really think it's a dup of bug 89345

Comment 2

17 years ago
I'm using 2001070604 WinNT.  I see this bug today but I don't see bug 89345 any
more (I did see it yesterday).


17 years ago
Keywords: regression
shouldn't || do the same thing as |ctrl+n|?  That is, open a window
and use the corresponding pref for whether to leave it blank or go to some
page?  It seems to be following the pref for me....

Granted, the behavior for |"")| seems to be wrong.  I'd expect that
to always open a blank page.

Comment 4

17 years ago
Another side effect of this that I'm seeing is: have a page use to
create a new window that loads a slow loading page.
You'll see your home page in the window before the new page loads in it.

Comment 5

17 years ago
*** Bug 90255 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
bz: IE and NS4 treat || as "open a blank window", so we should
probably go back to doing that as well.

Comment 7

17 years ago
This is IMO a stop ship regression.
Keywords: mozilla0.9.3
Target Milestone: --- → mozilla0.9.3

Comment 8

17 years ago
Yeah, loading the homepage before the real content is a big deal for users on
bad connections.
OS: Windows NT → All

Comment 9

17 years ago
It apparently affects users on "good" connections, as well. I'm connected via a
pretty decent cable modem, and it seems like the loading of the home page
interrupts the requested page.

Often (read: most of the time here) when clicking on a tag such as <A
HREF="" target="_blank">this one</A> the requested page
never gets displayed, only a small version of my home page.

*** Bug 90928 has been marked as a duplicate of this bug. ***
this is preventing Flashplayer pages from loading on Win98 build 

-select a version of the demo

a window pops open as expected with this site, but the page loaded is my home 
page not the Flash demo.

note: this Flashplayer problem is not affecting mac or linux.....however I do 
occasionally get my homepage appearing in pop up windows when visiting on both windows and mac, but not on linux.

Severity: major → blocker
Keywords: smoketest
Hardware: PC → All

Comment 12

17 years ago
branch only, not 100% reproducible, not a show stopper. Reducing severity to 
major to take off of blockers radar.
Severity: blocker → major

Comment 13

17 years ago
*** Bug 89622 has been marked as a duplicate of this bug. ***
my bad...this does not affect Flash player. It is working fine.  it just 
happened the page I was testing for flash attempted to open a new window with 
the Flash scene in it.....this bug prevented that from happening on my machines. 
 others (jj)  are not seeign the same behavior.


17 years ago
Keywords: smoketest

Comment 15

17 years ago
Seems to be a duplicate of bug 65993?

Comment 16

17 years ago
Yep, fixed in bug 65993 (which was reopened shortly after I filed this bug).

*** This bug has been marked as a duplicate of 65993 ***
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
verified dupe.
You need to log in before you can comment on or make changes to this bug.