b2g gralloc/genlock lockup while profiling on keon after graphics change

RESOLVED DUPLICATE of bug 896286

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 896286
5 years ago
5 years ago

People

(Reporter: jld, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 779667 [details]
backtrace of main thread

If I start b2g with the Gecko profiler enabled, and then visit a web page in the browser, the main process locks up.  This seems to be related to displaying the data transfer indicator in the upper bar.  (It also seems to occur sooner if MOZ_PROFILER_INTERVAL is set to 1, but I just reproduced it with the default.)  It seems to be blocking forever in an ioctl call for GENLOCK_IOC_LOCK (hardware/qcom/display/libgenlock/genlock.cpp:86); backtrace attached.

I bisected it to this change (commit hash is from the github m-c mirror, not g.m.o):

commit 572241784bb228b46c7436b87fca721c2c3ee89b
Author: Gabriele Svelto <gsvelto@mozilla.com>
Date:   Wed Jul 17 17:04:33 2013 +0200

    Bug 884188 - Resize small gralloc'd surfaces to work around issues when drawing small canvases on certain devices. r=nrc

 gfx/layers/ipc/ShadowLayerUtilsGralloc.cpp | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)


Running the profiler seems to be necessary to reproduce this, which suggests that signal handling is involved.  I haven't tried any other devices yet, so I don't know if they're affected as well.

For reference, gaia is 103f3635c (which is a little old, but it shouldn't be possible for gaia to cause this kind of failure, I don't think).
This is the second problem that change has caused after what we've seen in bug 873937 comment 70. We'll have to back it out and re-evaluate how to fix bug 888184.
Wrong bug in the comment above; I meant we have to find another way to fix bug 884188, not 888184.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896286
You need to log in before you can comment on or make changes to this bug.