CSS transition don't apply when a pseudo-element is set on a class that is added via JavaScript

RESOLVED DUPLICATE of bug 625289

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 625289
4 years ago
4 years ago

People

(Reporter: vincent, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.72 Safari/537.36

Steps to reproduce:

1. See Codepen here: http://codepen.io/anon/pen/Ektxm
2. Click on the red div, transitions works
3. Uncomment the content property on the ::after pseudo-element: transitions works only once




Actual results:

Transitions works only once when content property is set on ::after pseudo-element.


Expected results:

Transitions should work twice

Comment 1

4 years ago
I can reproduce this on Nightly ( Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20130722 Firefox/25.0 ). Moving to core.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
Version: 22 Branch → Trunk

Comment 2

4 years ago
(Core - General because I'm not entirely sure whether this is a CSS, DOM, or Layout issue)
OS: Windows XP → All
Hardware: x86 → All

Updated

4 years ago
Component: General → CSS Parsing and Computation

Updated

4 years ago
Flags: needinfo?(dbaron)
Adding/removing ::before causes a frame reconstruct, which is presumably confusing things here?
Whiteboard: DUPEME
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dbaron)
Resolution: --- → DUPLICATE
Duplicate of bug: 625289

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.