Flash does not restart after crash

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: rokeefe1, Unassigned, NeedInfo)

Tracking

22 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I notice that when Flash crashes when I am listening to Pandora I am unable to reload Pandora until I restart the browser.  I tried using other Flash sites and was unable to use the Flash on the sites until I restarted.  One way to test this without having to wait for a crash is to kill the Flash plugin processes.  Killing the plugin-container processes as well still does not cause Flash to respawn.


Actual results:

When Flash crashes it does not restart and flash cannot be used in Firefox without restarting the browser.


Expected results:

In previous versions of Firefox, when Flash crashed it would restart itself and Flash could be once again used in the browser.  The process no longer seems to respawn and Flash cannot be used without restarting the browser.

Comment 1

5 years ago
No problem for me in Nightly.
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Flags: needinfo?(rokeefe1)
(Reporter)

Comment 2

5 years ago
Maybe it's fixed in the newest build???

Doesn't starting in SafeMode disable the plugins?  How would that help to troubleshoot this issue?
(Reporter)

Comment 3

5 years ago
I should also add I'm using version 11.8.800.94 of Flash.
Flags: needinfo?(rokeefe1)

Comment 4

5 years ago
(In reply to rokeefe1 from comment #2)
> Doesn't starting in SafeMode disable the plugins?  How would that help to
> troubleshoot this issue?
A faulty extension might be the cause.
(Reporter)

Comment 5

5 years ago
Can Flash run in SafeMode?

Comment 6

5 years ago
(In reply to rokeefe1 from comment #5)
> Can Flash run in SafeMode?
Yes. Safe Mode only disables extensions and themes, not plugins.
(Reporter)

Comment 7

5 years ago
Here's what I discovered... if I run in SafeMode and kill the Flash process and then refresh a page that uses Flash the process respawns.  I tried also killing the plugin container and then refreshed the pages.  Both processes respawned.  I tried the same thing not running in SafeMode and got the same results.  It appears that this is a problem only when there is a true crash.  This morning I was on weather.com and got a message about Flash taking too long to run.  I selected the stop option.  As soon as I did that Flash crashed as expected.  However, when I refreshed my Pandora window Flash did not respawn.  Is there a way to simulate a long running flash plugin to try and reproduce this issue?  Otherwise this is going to be a very hard issue to reproduce consistently.

Updated

5 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
Hardware: x86_64 → x86
If i understand you right this is happening when the plugin gets stopped via the "unresponsive plugin " dialog?

(In reply to rokeefe1 from comment #7)
> Is there a way to simulate a long running flash plugin to try
> and reproduce this issue?.

You should be able to fake hangs using Process Explorer [1].
Right-click on the plugin-container.exe that has FlashPlayerPlugin_NN_NN_NNN_NN.exe as childs and choose "Suspend". After a bit, the hang UI should show up.

Can you reproduce with that?
Does the plugin-container stay around after you chose to stop the plugin?
Does it still happen on Firefox Nightly?

[1] http://technet.microsoft.com/de-de/sysinternals/bb896653.aspx
I tried the above process with Soundcloud and it works fine after reloading.
Flags: needinfo?(rokeefe1)
Works for me using latest Nightly 29.0a1 and latest Flash player build. Marking as resolved worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.