navigating session history quickly appears to lose form data

VERIFIED DUPLICATE of bug 93413

Status

()

Core
Document Navigation
P3
major
VERIFIED DUPLICATE of bug 93413
17 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: Radha on family leave (not reading bugmail))

Tracking

({dataloss, regression})

Trunk
mozilla1.0.1
x86
Windows NT
dataloss, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Go to http://www.cs.hmc.edu/~jruderma/s/.
2. Type a bug number into the bugzilla form (the second form on the page) and
press enter.
3. Wait for the bug to load (optional).
4. Hit the back button twice quickly.

Result: back at my home page, but the form isn't filled out.

5. Type 'g' into the google form and press enter.
6. Press back.

Result: the bugzilla form is now filled in with the bug number you typed in step
two.  The google query seems to have disappeared.
7. Type 'a' into the altavista form and press enter.
8. Press back.

Result: the bugzilla and altavista forms are now filled in.  The google search
is still lost.
This is a dataloss bug, mostly after step 4 (because most users won't figure out
the workaround), but also after step 6.

Happens in 2001 070604 on WinNT.  Doesn't happen in 2001 0628, so it's a recent
regression.
(Reporter)

Updated

17 years ago
Keywords: dataloss, regression
(Reporter)

Comment 1

17 years ago
Ok, I figured out the pattern here.  The problem isn't the redirect; it's that
session history gets confused with regard to form-refilling when I press back or
forward while going back or forward.  That is, after (hitting back+back,
forward+forward, forward+back, or back+forward) *quickly*, the resulting page
will not have its form elements filled with the values they had before.

Resummarizing from "form submission leads to redirect -> form data not
remembered after hitting back" to "navigating session history quickly appears to
lose form data".
Summary: form submission leads to redirect -> form data not remembered after hitting back → navigating session history quickly appears to lose form data
(Reporter)

Comment 2

17 years ago
This bug still exists in 2001 071304.  It's also a problem on the branch.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0.1
(Reporter)

Comment 3

17 years ago
See also bug 93413, Going Back while page was loading makes form fields 
disapear on previous page.

Comment 4

17 years ago
I'm marking this as a dupe of 93413, which seems to be the same problem (it
might be a dupe of bug 41555, but that bug is a bit old and non-specific.), but
has a easier reproduction summary.

*** This bug has been marked as a duplicate of 93413 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
VERIFIED Dupe

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.