Closed Bug 897036 Opened 6 years ago Closed 6 years ago

Dialer app remains at 10% loading when test_call_log_all_calls is run

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

VERIFIED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: AlinT, Assigned: ferjm)

References

Details

(Keywords: regression)

Attachments

(3 files)

This is only reproducible on v1-train branch and only during automation.

Manual steps to reproduce:
1. Open Dialer app
2. Tap Call Log

Expected results:
Call log should display the list of calls made.

Actual results:
Dialer app remains at 10% loading. The Dialer app is also unresponsive.

The problem is that this is not reproducible manually.

To reproduce this issue you have to run the following test, https://github.com/mozilla/gaia-ui-tests/blob/v1-train/gaiatest/tests/dialer/test_call_log_all_calls.py , on the latest v1-train build

there is the adb logcat during the test: http://pastebin.mozilla.org/2693962

Regression range:
The last "good" build(the problem is not reproducible on) is: https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/2013/07/2013-07-21-23-02-04/
This issue has started with build: https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/2013/07/2013-07-21-23-02-04/
And it is also reproducible on today's build: https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/2013/07/2013-07-22-23-02-03/
Attached image Screenshot of the issue
Revision numbers:

last good build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia   06d56e0efd1cb3bbed37fef6ee45233b86b3ae3b
BuildID 20130721230204
Version 18.0

The build where the issue has started:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia   41d10fb10be6916e6554eb440d9a97130ef23ce0
BuildID 20130722070207
Version 18.0
Nice report AlinT! 
I have seen this in the Leo automation too which is also running on the v1-train builds.
I can replicate this on a master build, and manually too!

All you have to do is remove the indexedDB files and you can replicate this on first launch of the Phone app.

$ adb shell stop b2g
$ adb shell rm -r /data/local/indexedDB
$ adb shell start b2g

I'll see if reverting the Gaia commit mentioned in comment 5 makes a difference.
Yes, it would appear that https://github.com/mozilla-b2g/gaia/commit/41d10fb10be6916e6554eb440d9a97130ef23ce0 introduces this issue. I wasn't able to revert it due to conflicts, but the revision immediately before does not replicate the issue.
Component: Marionette → Gaia::Dialer
Product: Testing → Boot2Gecko
blocking-b2g: --- → leo?
Severity: normal → major
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Ok we'll incorrectly block this as NPOTB since it affects automation but has no sign of having significant user impact.
blocking-b2g: leo? → leo+
Whiteboard: [NPOTB]
Duplicate of this bug: 897297
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> Ok we'll incorrectly block this as NPOTB since it affects automation but has
> no sign of having significant user impact.

This is incorrect. The dupe proves this is happening on real devices with STR included on the other bug. It was also found on b2g18 and central during daily smoke testing.
Keywords: regression
Whiteboard: [NPOTB]
this is reproducible on master to

Gecko  http://hg.mozilla.org/mozilla-central/rev/a4c1961bf723
Gaia  c7272f0b45c9fdac9d551828987e343300e87bf6
BuildID 20130725030211
Version 25.0a1
(In reply to Florin Strugariu [:Bebe] from comment #11)
> this is reproducible on master to

As already mentioned in comment 6
Fernando - Can you confirm this is a regression from bug 862385?
Flags: needinfo?(ferjmoreno)
Might be. I'll take a look.
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
Attached patch v1Splinter Review
Attachment #781624 - Flags: review?(francisco.jordano)
We were not notifying that the upgrade was done when there were no call groups to migrate.
Comment on attachment 781624 [details] [diff] [review]
v1

Thanks Fernando.
Attachment #781624 - Flags: review?(francisco.jordano) → review+
https://github.com/ferjm/gaia/commit/1d308bd461365ed305aeb6f30743a39aab22d00d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This issue was reproducible both on v1-train and master branch, and now it is Verified Fixed only on master branch.
The issue is still reproducible in v1-train branch!
Can someone uplift this in v1-train?
Uplifted 1d308bd461365ed305aeb6f30743a39aab22d00d to:
v1-train: 97fd66454d8b19cc9c79033c492ae676a613229d
Verified fixed on v1-train and master.
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/ba71c64705e5
Gaia   ddb922ed002e88d01f71199da32ff75911b455b2
BuildID 20130801231202
Version 18.0
Status: RESOLVED → VERIFIED
Issue Do not reproduces on Leo
Build ID: 20130805071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
Call log show display the list of calls made.
v1.1.0hd: 97fd66454d8b19cc9c79033c492ae676a613229d
Blocks: 903027
No longer blocks: 903027
You need to log in before you can comment on or make changes to this bug.