Users in Seahorse still prompted with MT authorization

RESOLVED WORKSFORME

Status

Marketplace
Payments/Refunds
P1
blocker
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: Keir Kettle)

Tracking

Points:
---
Bug Flags:
affects-seahorse +

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 779905 [details]
seahorse.txt

test env: stage
gaia: 1.01
SIM: none

steps to reproduce:
1. Launch marketplace stage
2. Log in with a brand new account
3. Start the purchase of a paid app
4. Create and Confirm PIN


expected behavior:
Credit card screen from Bango loads for users in Seahorse.

observed behavior:
MT authorization screen loads.
(Reporter)

Updated

5 years ago
Flags: affects-seahorse+

Updated

5 years ago
Assignee: nobody → keir
I can confirm that we are passing MOZ_USER_ID as a billing config parameter in our staging environment https://github.com/mozilla/solitude/blob/master/lib/bango/resources/billing.py#L121

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
Severity: major → blocker

Comment 2

5 years ago
This should be resolved now. Users were using TEST and not production.

Users are getting other issues now related to Country mismatch because not using VEN credit cards.

Comment 3

5 years ago
We saw a high numbe rof not_supported errors last night. This was resulted from users in Seahorse using credit cards not from Seahorse country which resulted in a Country_Mismatch error which each user received 4 times before being barred for CC payments. The resultant Not_supported error relates to the attempt on our system to push the transactions through the next available payment method on billrank which after CC fails would be operator billing. However, becuase OB is not setup for Seahorse that is why it fails with a not_supported error.

Lastly, When users are receiving the MT auth screen the only reason will be because the user is coming through an IP address recognised as non-Seahorse. We have seen a number of these occuring on Test in recent days because users are showing up on a Colombia, Brazil, US or Malaysian IP address.

Comment 4

5 years ago
Please test using Mozilla Marketplace Stage which connects to Bango Production and live cc payments. If you continue to have failing payments, please message me and I will try to assist with a USD credit card
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

5 years ago
(In reply to Steve Ruston from comment #4)
> Please test using Mozilla Marketplace Stage which connects to Bango
> Production and live cc payments. If you continue to have failing payments,
> please message me and I will try to assist with a USD credit card

This was being tested in stage. Marketplace dev is completely mocked out. Steps in comment 0 clearly indicate that stage was being used.
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.