Add a way for calling a widget's item's methods

RESOLVED DUPLICATE of bug 892605

Status

RESOLVED DUPLICATE of bug 892605
5 years ago
4 months ago

People

(Reporter: fitzgen, Unassigned)

Tracking

25 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

For example, we want to set checkbox state on a given item, from a SideMenuWidget.
Victor: IIRC, we wanted to add a method like `callItemMethod(methodName, ...args)` or something to Widget and then the items that you push would have to implement `item.methodName(...args)` right?
Flags: needinfo?(vporof)
I would vote for the former approach, so we don't write two methods in both places for every new piece of functionality. It's pretty meta, but elegant enough.

This should be a good first step towards bug 895514 and perfect for solving that bug you had with checking the checkboxes.
Flags: needinfo?(vporof)
Wait, my memory has become foggy, can you quickly outline what we planned on doing again? Sorry :-/
This work is subsumed by bug 892605
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 892605

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.