VariablesView search is slow

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Object Inspector
P3
normal
RESOLVED WONTFIX
5 years ago
3 months ago

People

(Reporter: benvie, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Searching the VariablesView is slow (100ms+) when there's an object with a lot of properties (such as the ChromeWindow in the error console). This is probably because the search updates attributes for properties individually, each causing a reflow. This could probably be remedied by detaching the parent element, executing the search, and reattaching it.
(Reporter)

Comment 1

5 years ago
Detaching/reattaching the VariablesView's _list does not noticeably help performance. This will need more in depth examination.
(Reporter)

Updated

5 years ago
Priority: -- → P3
(In reply to Brandon Benvie [:bbenvie] from comment #0)

Isn't this because of the timeout set before actually starting the search? Does hitting Enter or searching for longer keywords alleviate the situation?
(Reporter)

Comment 3

5 years ago
(In reply to Victor Porof [:vp] from comment #2)
> Isn't this because of the timeout set before actually starting the search?
> Does hitting Enter or searching for longer keywords alleviate the situation?

No, I think it's definitely something performance related, because the UI becomes unresponsive. Steps to reproduce:

* Go to the browser console and open `this` up in the VariablesView
* type "Add"
* rapidly backspace three times

You will see it immediately backspace the first "d" and regenerate the list, then the UI will stall for 50-100ms before removing the second "d" and regenerating the list. Also doing <backspace> <backspace> <enter> doesn't make it respond any faster.
The vview is only used in scratchpad and webaudio now. Closing this old bug.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.