offline: news: Get Selected Messages and Get Flagged Messages doesn't behave correctly for newsgroups

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Observed in
2001-07-06-09-trunk/ win nt 4.0
2001-07-06-08-trunk/ linux 2.2, red hat 7.0
2001-07-06-08-trunk/ mac os 9.0.4

Seeing strange behavior when it comes to using Get Selected Messages
or Get Flagged Messages for newsgroups.

For Get Flagged Messages:
  1. Subscribe to a newsgroup (if not already)
  2. get all the headers (better yet mark all messages as read)
  3. Make sure you display the flag column in the thread pane
  4. flag at least 3 messages
  5. make sure you are not selecting any of the 3 flagged messages
  6. go to File|Offline|Get Flagged messages
  7. go offline 
  8. Click on each of the 3 flagged messages you downloaded

  Results: 1st flagged message is not downloaded. And what really
           is strange is that when it is done downloading flagged
           messages, the flag is removed. Sometimes all 3 flags
           are removed, other times only one or two of the flags
           are removed
  Expected results: 3 messages to be downloaded and all 3 to have
            their flags still present. Mail behaves this way.

For Get Selected Messages:
  1. Subscribe to a newsgroup (if not already)
  2. get all the headers (better yet mark all messages as read)
  3. select at least 3 messages
  4. go to File|Offline|Get Selected messages
  5. go offline 
  6. Click on each of the 3 selected messages you downloaded

  Results: 1st selected message is not downloaded, the others are. 
  Expected results: 3 messages to be downloaded 

Not sure if this is a front end or back end issue.
(Assignee)

Comment 1

17 years ago
it looks to me from testing like we're just skipping the first flagged or
selected message and downloading the rest. Should not be hard to fix.
(Assignee)

Comment 2

17 years ago
Created attachment 42487 [details] [diff] [review]
proposed fix
(Assignee)

Comment 3

17 years ago
adding Navin and Seth for reviews. We were skipping the first message, so I used
the existing firstTimeP parameter to know if we'd already figured out which
message to download.
Status: NEW → ASSIGNED

Comment 4

17 years ago
r=naving 
(Assignee)

Comment 6

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

17 years ago
Commercial builds:
2001-08-15-09-trunk/ - nt 4.0
2001-08-15-14-trunk- linux 2.2, mac 9.0.4

verified flagging unread and read newsgroup messages results
in those messages being downloaded. 

Note: the Flag dissapears after doing a "Get Flagged message".
      This isn't considered a bug I hope? If it is, I'll open
      a new bug, David.

Marking as verified (both themes)

Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

17 years ago
no, that's the intended behaviour, the useage model being that you flag
interesting messages as you read them online, then download them for offline, at
which point you want to unflag them, so that when you go online and download
messages again, you'll be starting with a clean slate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.