Closed Bug 897300 Opened 6 years ago Closed 6 years ago

WebRTC Pulse driver does not build

Categories

(Core :: WebRTC: Audio/Video, defect)

24 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24
Tracking Status
firefox23 --- affected
firefox24 --- fixed
firefox25 --- unaffected

People

(Reporter: heftig, Assigned: jesup)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130722 Firefox/24.0 Aurora/24.0a2 (Nightly/Aurora)
Build ID: 20130722024604

Steps to reproduce:

Tried to compile with --enable-pulseaudio.


Actual results:

Build failure:

/build/aurora/src/mozilla-aurora/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.cc: In constructor 'webrtc::AudioDeviceLinuxPulse::AudioDeviceLinuxPulse(WebRtc_Word32)':
/build/aurora/src/mozilla-aurora/media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_pulse_linux.cc:82:5: error: class 'webrtc::AudioDeviceLinuxPulse' does not have any field named 'sample_rate_hz_'


Expected results:

Looks like the patch from http://review.webrtc.org/1384004/ was not applied correctly, and the field in audio_device_pulse_linux.h was named sampling_rate_hz instead of the sample_rate_hz_ the rest of the code uses.
Blocks: 886886
doing a check build now
Attachment #780158 - Attachment is obsolete: true
Attachment #780163 - Flags: review?(paul)
Attachment #780163 - Flags: review?(paul) → review+
Comment on attachment 780163 [details] [diff] [review]
Correct mis-merge for pulse audio on Aurora from bug 886886

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 886886 (merge to aurora)

User impact if declined: --enable-pulse is broken; breaks all BSD ports

Testing completed (on m-c, etc.): on m-c; corrects mis-merge

Risk to taking this patch (and alternatives if risky): none

String or IDL/UUID changes made by this patch: none
Attachment #780163 - Flags: approval-mozilla-aurora?
Attachment #780163 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/64c5cc9bad2e
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Assignee: nobody → rjesup
Blocks: 903549
Duplicate of this bug: 903549
You need to log in before you can comment on or make changes to this bug.