[Helix] Unable to launch Usage app.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: atsai, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 780146 [details]
2013-07-26-00-26-38.png

After launch Usage app, it only stuck in a page with usage app icon on it. Unable to use it. Not sure if this has anything to do with #894040

* Build
Gaia:     f851c8834688d8d960562ec55253dd44051929cd
  B-D     2013-07-16 10:48:05
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/034825df3f19
BuildID   20130715230201
Version   18.0
(Reporter)

Updated

5 years ago
Group: mozilla-corporation-confidential
CC list accessible: false
Not accessible to reporter
(Reporter)

Updated

5 years ago
No longer depends on: 894779
(Reporter)

Updated

5 years ago
Duplicate of this bug: 894779
The commit you are pointing with latest Gecko breaks almost all Gaia due to the IccInfo has been moved to another API. Recent versions of Gaia does not have this problem as a module called IccHelper has been added to ease the transition from the older API to the new one.

WHat should we do?
Flags: needinfo?(atsai)
(Reporter)

Comment 3

5 years ago
I believe you can still reproduce it with master/central combination. It seems the cost control app and the SIM card function are totally broken.
Flags: needinfo?(atsai)
Nope. In master is not reproducing.

Comment 5

5 years ago
With latest partner build 0723 and replaced oeminfo.mbn asked by partner, Usage app can be accessed now.

Verified on 
Gaia:     1cb40adb9478f91a7ef0f43928e2471b8fb10bf0
  B-D     2013-07-24 19:06:27
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/2bb08f2878da
BuildID   20130724070202
Version   18.1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Although already resolved. but should be blocking if bug exists.
blocking-b2g: hd? → hd+

Comment 7

5 years ago
Thanks for your help!
I cannot reproduce this bug on the following build.
* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-12-04-22-03)
  + Mercurial-Information
    - Gecko revision="afd50da34b9f"
  + Git-information
    - Gaia revision="134356dc21d0627455f8bc536b140a18f39e20e9"

Comment 8

5 years ago
I cannot reproduce this bug on the following build.
* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-18-04-22-03)
  + Mercurial-Information
    - Gecko revision="920aa4fd19e2"
  + Git-information
    - Gaia revision="b99a607f0416882587c608182f2bf5af49fce48f"

Marked as "Verified"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.