Web inspector escapes altered attribute data

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: pqwoerituytrueiwoq, Unassigned)

Tracking

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This is a lot like this old bug from 2001 (that was fixed)
https://bugzilla.mozilla.org/show_bug.cgi?id=68167
When I set the onclick attribute to something like alert('hello world')
It escapes the single quotes which results in a syntax error when the JS is run
Screenshot:
http://www.zimagez.com/zimage/screenshot-07242013-023553am.php

Comment 1

2 years ago
Created attachment 8799321 [details]
escape-apostrophe.png

Would you please provide detailed steps to reproduce the bug? I can't reproduce it.

Comment 2

2 years ago
I see it in Fx25.0.1, WFM in 50b11.
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Last Resolved: 2 years ago
Component: Developer Tools: Object Inspector → Developer Tools: Inspector
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.