Combo boxes and select boxes are not working in 0.9.2 and above

RESOLVED DUPLICATE of bug 32198

Status

()

--
major
RESOLVED DUPLICATE of bug 32198
17 years ago
17 years ago

People

(Reporter: pnrjack, Assigned: rods)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I am unable to use any forms that have combo boxes or select boxes in the 
latest Mozilla release 0.9.2 and above.  I have just tried again with the 
latest nightly build and the defect is still present so I am reporting it.

Comment 1

17 years ago
Over to HTML Form Controls, severity->major.

Which OS are you using? In which way are you unable to use the forms? Do they
not react to clicks, or is the data not send correctly?

Please read the bug reporting guidelines at
http://www.mozilla.org/quality/bug-writing-guidelines.html and consider using
Bugzilla Helper at http://www.mozilla.org/quality/help/bugzilla-helper.html to
report bugs. Thanks for using Mozilla!
Assignee: asa → rods
Severity: normal → major
Component: Browser-General → HTML Form Controls
QA Contact: doronr → madhur
(Reporter)

Comment 2

17 years ago
  I am using windows Me as the OS.  The way that the combo boxes are not 
working is that the actual widget is not being displayed.  The elements of the 
widget are below the place where the combo box is supposed to be located, but 
the combo box is showing up as a vertical millimeter wide box as if it was a 
textfield without a size assigned to it.  Am I making sense? If not, just email 
me back.  I just downloaded this morning's build, and it is still occurring.
  Rick Jackson
  pnrjack@bellsouth.net

Comment 3

17 years ago
I'm seeing some combo's work, but others not. For instance bugzilla seems fine,
but www.sony.com neither of the comboboxes work. I'm using Win2k with source
from CVS from a pull on Thursday.

Comment 4

17 years ago
Rick Jackson, can you tell us if any other sites are having problems? Do any
combo boxes at any site work for you?
(Reporter)

Comment 5

17 years ago
  Hello,

  I have build 2001070808.  I have gone to every site that I can think of that
would have a combo box, and they all seem to be working.  I don't know what
changed if anything, but I am definitely not seeing the defect in yesterday's
build.  The combo boxes are displaying appropriately.  However, if you go to
www.sony.com the combo boxes are there, but nothing happens if you click on
them.  I have tried numerous times, and I am seeing the same result.

Comment 6

17 years ago
Some more odd information on the www.sony.com issue. I downloaded the frame
source locally (index4.htm). When I viewed it locally, the combo's worked. I
also tried http://www.sony.com/index4.htm and the combo's don't work.

This site is also missing a number of images that appear on IE. These pictures
appear in a table. I think the combo's are just a symptom of another problem
dealing with the images and/or the JS on the page.

Also if I double click on the combo box it paints some blocks to the right of
the combo box. It only does this on the Quick Link Combo.

So the www.sony.com issue is a different issue than the original issue here.
Should we mark this and create a new bug for Sony, or just morph this to deal
with the Sony issue?

Comment 7

17 years ago
You may want to check out event handling and property assignment in select boxes
for 0.92 at least (the version I am having problems with). I have been unable to
assign new properties to select boxes. I have had to assign to the first select
option (form.selectElement.options[0]) as a workaround. Additionally, a friend
has had problems getting onchange to fire.

Comment 8

17 years ago
looks like a duplicate of bug 32198

Comment 9

17 years ago
I am having these problems too, especially at www.sony.com

Comment 10

17 years ago
Yeah looks like SOnys site.

*** This bug has been marked as a duplicate of 32198 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.