Closed Bug 897494 Opened 9 years ago Closed 9 years ago

[SMS] should not detect a number starting the next word for part of the phone number

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

VERIFIED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: isabelrios, Assigned: gnarf)

Details

(Whiteboard: MMS_TEF, [LeoVB+], [leo-triage])

Attachments

(1 file)

Unagi device v1-train build:
Gecko-f94f793
Gaia-ef03c2b
ref ril

STR
1. Create a new SMS with for example: '600123123 1Test'
2. Send it

EXPECTED
The number is underlined and tapping or long tapping on it will bring up the corresponding options (Call, Create as a new contact, Add to an existing one).

ACTUAL
The number is not detected as a link but also considering the number of the word: '600123123 1' appears all underlined

Similar situations where solved by bug892480 and bug895307 but this is a new scenario.
Assignee: nobody → gnarf37
Summary: Follow up bug895307 [SMS] should detect phone numbers when then word after it starts with a number → [SMS] should not detect a number starting the next word for part of the phone number
Attached patch patch v1Splinter Review
Attachment #780476 - Flags: review?(schung)
Leo - is this critical for you all? Not a blocker from our end, given where we are in the cycle.
Flags: needinfo?(leo.bugzilla.gaia)
From the engineering side - It's a trivial fix, low risk, highly unit tested section of code.
Not able to reproduce this issue on Leo Device.
Flags: needinfo?(leo.bugzilla.gaia)
Comment on attachment 780476 [details] [diff] [review]
patch v1

This issue is reproducible for me in master and v1-train, and the patch provide a better phone number matching RegExp here. I think we should fix this issue with low cost like this one.
Attachment #780476 - Flags: review?(schung) → review+
Neither partners nor Mozilla triage believe this is a blocker.
blocking-b2g: leo? → -
We do think this issue is a blocker and we would like to know if other partners using a most updated v1-train release are reproducing it before decreasing the priority.
Adding in CC David and Joe who can contact other partners and provide feedback.
master: https://github.com/mozilla-b2g/gaia/commit/b1ea7ffb32ecd0ab9ff6b263c4363c314e0909a5

It is a pretty tiny commit and could be uplifted very easily if you decide to.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: MMS_TEF → MMS_TEF, [LeoVB+]
Hi, 

I think it's worth to uplift this non-risky patch. Nominating to leo? for discussion... 

Thks!
David
blocking-b2g: - → leo?
Triage - partner has already taken this patch into Leo. Leaving Mozilla triage to decide on comment 9.
Whiteboard: MMS_TEF, [LeoVB+] → MMS_TEF, [LeoVB+], [leo-triage]
With partner already taking it doesn't leave us much choice, marking leo+ for uplift to v1.1
blocking-b2g: leo? → leo+
Uplifted b1ea7ffb32ecd0ab9ff6b263c4363c314e0909a5 to:
v1-train: 036ace563d1dd8f531665b7cd5f291be6e57dc05
Verified with unagi device 06/08 v1-train build:
Gecko-8878e8a
Gaia-271fb72
Ref ril
Status: RESOLVED → VERIFIED
v1.1.0hd: 036ace563d1dd8f531665b7cd5f291be6e57dc05
You need to log in before you can comment on or make changes to this bug.