Crash with Adblock Plus installed in java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp$26.onBitmapFound(BrowserApp.java)

VERIFIED FIXED in Firefox 25

Status

()

Firefox for Android
General
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mfinkle, Unassigned)

Tracking

({crash, regression})

25 Branch
Firefox 25
All
Android
crash, regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

Created attachment 780432 [details] [diff] [review]
null-item

This bug was filed from the Socorro interface and is 
report bp-34c643c8-c30b-4682-8850-9f2d52130724 .
 ============================================================= 

Looks like the MenuItem is not being found. I don't know why.
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/BrowserApp.java#1454

This patch just tests for a null item and returns without setting any icon.
Attachment #780432 - Flags: review?(sriram)
Attachment #780432 - Flags: review?(sriram) → review+

Updated

5 years ago
Duplicate of this bug: 897509

Comment 2

5 years ago
A regression range is in the duplicate.
Severity: critical → blocker
tracking-fennec: --- → ?
status-firefox24: --- → unaffected
status-firefox25: --- → affected
tracking-firefox25: --- → ?
Keywords: regression
Whiteboard: [native-crash]
Version: Trunk → Firefox 25

Comment 3

5 years ago
Got a bunch of these on Nightly on a Kindle Fire after installing AdBlock Plus add-on.

Crashes went away after uninstalling the add-on.

Submitted Crash Reports
Report ID 	Date Submitted
bp-428ac391-96a1-4469-b30d-2a7972130725	07/24/13	20:26
bp-59acc1da-2d99-43fb-b2cf-6fca42130725	07/24/13	20:25
bp-26c85762-fe3c-44c3-82c8-fd4c22130725	07/24/13	20:25
bp-1017e98c-3500-4f01-aba8-71eca2130725	07/24/13	20:24
bp-dc2fc168-7890-4c7c-b649-c323a2130725	07/24/13	20:23
bp-aab44c89-4892-4323-946d-7cb4d2130725	07/24/13	20:23
bp-74b84a32-1300-4e29-b784-3b3cf2130725	07/24/13	20:22
bp-389b088d-63ef-4137-b28a-3bf942130725	07/24/13	20:21
Summary: crash in java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp$26.onBitmapFound(BrowserApp.java) → Crash with Adblock Plus installed in java.lang.NullPointerException: at org.mozilla.gecko.BrowserApp$26.onBitmapFound(BrowserApp.java)

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/7ed869796922
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25

Comment 6

5 years ago
Can someone respin a new Nightly containing this patch?
Checked in #mobile and according to mfinkle the respin is in progress.
(In reply to Kevin Brosnan [:kbrosnan] from comment #7)
> Checked in #mobile and according to mfinkle the respin is in progress.

Respin is done and on ftp, was off this cset:

https://tbpl.mozilla.org/?rev=8196c86355bc

Updated

5 years ago
status-firefox25: affected → fixed
tracking-firefox25: ? → ---
tracking-fennec: ? → ---
Verified fixed on:
Build: Firefox for Android 25.0b1 (2013-09-18)
Device: LG Nexus 4 
OS: Android 4.2.2
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
You need to log in before you can comment on or make changes to this bug.