[Fig] Urlbar resize for entry is incorrectly rendered

VERIFIED FIXED in Firefox 26

Status

()

Firefox for Android
Theme and Visual Design
P1
normal
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: liuche, Assigned: liuche)

Tracking

({regression, reproducible})

unspecified
Firefox 26
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(fennec26+)

Details

Attachments

(3 attachments)

Created attachment 780499 [details]
Screenshot: urlbar resize

On the HTC One V running Android 4.0.3, urlbar resize doesn't refresh the images correctly. (This looks fine on the Galaxy Nexus running 4.2.2 and the Nexus S running 2.3.4.)

Can someone try to repro on some other 4.0 phones?
OS: Mac OS X → Android
Hardware: x86 → ARM

Updated

4 years ago
Blocks: 862793
Chenxia, can you still reproduce? I couldn't...
Flags: needinfo?(liuche)
Marking as p1, looks serious (if it's easily reproducible on some devices)
Priority: -- → P1
I just updated to the latest fig nightly (8/13) and I still see this.

The device is my personal phone, HTC One V, running 4.0.3. I can't seem to find any other 4.0.3 non-tablets to check on.

QA: can you try to verify on different 4.0.3 phones?
Flags: needinfo?(liuche)
Keywords: qawanted
I just tried this out on a Motorola 4.0.4 phone, and couldn't repro it.
I cannot reproduce this on Samsung Galaxy Tab (Android 4.0.4) on latest fig nightly.
Hey Aaron, do you have any device with Android 4.0.3 to try this?
Flags: needinfo?(aaron.train)
Created attachment 790213 [details]
Fig Nightly (08/14)

Reproducible on the first Android 4.0.4 I picked up. Alcatel One Touch 997.
Flags: needinfo?(aaron.train)

Updated

4 years ago
Keywords: qawanted → regression, reproducible
Landscape orientation is unaffected.

Updated

4 years ago
tracking-fennec: --- → ?
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
Assignee: lucasr.at.mozilla → sriram
Created attachment 801935 [details] [diff] [review]
Patch: fix clipping by increasing to 60%

The problem seems to have been that the urlbar that is clipped for the right side is too small - I increased the hard-coded value to 60%.

AaronMT: Can you verify that this build fixes the problem on your device?
http://people.mozilla.org/~liuche/bug-897571/
Attachment #801935 - Flags: review?(sriram)
Flags: needinfo?(aaron.train)
Sure. I won't have access to the device until Wednesday. Was anyone else reading this able to reproduce that can take a look?
Flags: needinfo?(aaron.train)
Comment on attachment 801935 [details] [diff] [review]
Patch: fix clipping by increasing to 60%

Review of attachment 801935 [details] [diff] [review]:
-----------------------------------------------------------------

:P
Attachment #801935 - Flags: review?(sriram) → review+
Assignee: sriram → liuche
Aaron: I was able to verify this fix on my HTC One V, but I'd like to see the fix working on other devices before landing it.
(In reply to Chenxia Liu [:liuche] from comment #9)
> Created attachment 801935 [details] [diff] [review]
> Patch: fix clipping by increasing to 60%
> 
> The problem seems to have been that the urlbar that is clipped for the right
> side is too small - I increased the hard-coded value to 60%.

Nice catch :-)
Sorry for the delay. Yes, the above patch and custom build resolves this on my reproducible device.

Land it!
Status: NEW → ASSIGNED
https://hg.mozilla.org/integration/fx-team/rev/906d83601f14
https://hg.mozilla.org/mozilla-central/rev/906d83601f14
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.