[Buri][Contacts]The contact pic display abnormal when link contact with Gmail and facebook

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: jmcf)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.164
 Firefox os  v1.1
 Mozilla build ID:20130715070218
 
 
 
 Created an attachment (id=468762)
 pic
 
 DEFECT DESCRIPTION:
  The pic was not the same
  REPRODUCING PROCEDURES:
  1.Log in Gmail,import a contact A which have head portrait
  2.Edit this contact,Link contact,Select a Facebook Friend which have a different head portrait
  3.Back to Contacts,The contact A displayed Gmail's contact pic
  4.Edit this contact,it displayed the Gmail's contact pic
  5.Close the Contacts progress,Launch Contacts again
  6.The Contact A head portrait was changed---->KO
  EXPECTED BEHAVIOUR:
  The pic should stay the same
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Mid 
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Created attachment 780747 [details]
pic
(Reporter)

Comment 2

5 years ago
Clone from brother
(Reporter)

Comment 3

5 years ago
Created attachment 780749 [details]
pic
(Reporter)

Comment 4

5 years ago
Created attachment 780750 [details]
pic_2

Comment 5

5 years ago
this is block pr.please update status,thanks.
blocking-b2g: --- → leo?
Is this a regression from v1.0.1?
Keywords: qawanted

Updated

5 years ago
QA Contact: nkot

Comment 7

5 years ago
the same behavior is observed on v1.0.1 (if I understand the issue correctly)

 1. the user creates a contact with picture (no option to import from gmail on v1.0.1)
 2. the user links this contact to a Facebook contact
  ==> the contact has original picture in contact details and in Contacts list
 3. the user restarts Contacts app
  ==> the contact has now Facebook picture in Contacts list,
      there is still original picture in contact details, though it appears zoomed in a little

Build ID: 20130525070214
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9ce68012f9da
Gaia: 26d9430df4cd670e46a208a6e4b6d77e4b27ed75
Platform Version: 18.0
Keywords: qawanted
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 8

5 years ago
Created attachment 783027 [details]
Pointer to GH PR ##11245
Attachment #783027 - Flags: review?(bkelly)
Comment on attachment 783027 [details]
Pointer to GH PR ##11245

Looks good!  I posted a few minor nits in the pull request.  I also had a concern about how we handle the case where the local photo is deleted after the FB data is loaded, but I think that will be ok due to the way the list refresh() is implemented.  Thanks!  r+
Attachment #783027 - Flags: review?(bkelly) → review+
Given comment #7, looks like it is not a regression and this can be resolved in future release.
blocking-b2g: leo? → -
(Assignee)

Comment 11

5 years ago
yes, fixed in master and should be available for Koi. 

https://github.com/mozilla-b2g/gaia/commit/26a853cc03a54ac2341c7b7d6c386d58670f75eb
Status: NEW → RESOLVED
blocking-b2g: - → koi?
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 12

5 years ago
Dear jmcf:
   can you merge the patch to v1.1?
(Assignee)

Comment 13

5 years ago
Sorry, if it is not marked as leo it cannot be uplifted
blocking-b2g: koi? → koi+
if you want it to be in v1.1, please change it to leo?
Flags: needinfo?(buri.blff)

Comment 15

5 years ago
Yes, it should be in v1.1, thanks.
blocking-b2g: koi+ → leo?
Flags: needinfo?(buri.blff)

Comment 16

5 years ago
Dear Joe,
please merge the patch to v1.1,thanks.
This is not a regression, so this is not a blocker and therefore cannot land to 1.1. This will be fixed for the first time in 1.2.

Please see email sent to b2g-partner-announce@mozilla.org (all partners) about blocking criteria. Thanks!
blocking-b2g: leo? → -

Comment 18

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #17)
> This is not a regression, so this is not a blocker and therefore cannot land
> to 1.1. This will be fixed for the first time in 1.2.
> 
> Please see email sent to b2g-partner-announce@mozilla.org (all partners)
> about blocking criteria. Thanks!

this will affect user experience. What we need is a product not a toy.
we can do better, why we don't do?
You need to log in before you can comment on or make changes to this bug.