[Buri][camera]It display abnormally when plug in USB to preview video

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: johnhu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.164
 Firefox os  v1.1
 Mozilla build ID:20130715070218
 
 Created an attachment (id=467620)
 PIC
 
 DEFECT DESCRIPTION:
  It display abnormally when plug in USB to preview video
  REPRODUCING PROCEDURES:
  1.Enable USB storage
  2.Launch camera app
  3.Switch to Camcorder
  4.Record  a video
  5.Tap the video on the left top to preview
  6.Plug in USB,then press play key->the screen display abnormally->KO
  EXPECTED BEHAVIOUR:
  It should have notification that can't preview
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Mid
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 780825 [details]
PIC
Component: Gaia::Video → Gaia::Camera
I confirmed this happens on v1.1 hamachi. It seems that camera app does not care about this use case.
Assignee: nobody → johu
Created attachment 781538 [details]
change css z-index and make camera go back to camera mode while usb is plugged

The correct behavior should be to show an overlay saying storage is mounted as USB device. And preventing user to play the video.

This bug has two sub-issues:
1. Message overlay should be higher than media frame. They are at the same level 100. So, I make message overlay(110) higher than media frame(100).
2. When media frame is shown, it may be a case of playing video.  Camera app may be  killed because of locked file when user plug USB in. So, I change the code to go back to camera mode when sdcard becomes unavailable or shared.
Attachment #781538 - Flags: review?(dflanagan)
Comment on attachment 781538 [details]
change css z-index and make camera go back to camera mode while usb is plugged

r+.  But please see the name change suggetions on github. You can land this patch as it is if you want, but I'd prefer to take this opportunity to fix the very confusing "returnToCamera" variable.
Attachment #781538 - Flags: review?(dflanagan) → review+
Comment on attachment 781538 [details]
change css z-index and make camera go back to camera mode while usb is plugged

David, 

Sorry to reset the review flag from + to ?. Besides last changes, I added some changes of variables and functions renaming to make code more clear. So, it is nice to review it again.

Change items:
1. make camera go back to camera mode while usb is plugged
2. remove returnToCamera variable, use Filmstrip.isPreviewShown() to replace it.
3. rename the returnToCameraMode to hidePreview()
4. add isPreviewShown and hidePreview to Filmstrip
5. rename the screenWakeLock and screenTimeout to requestScreenWakeLock and releaseScreenWakeLock.
6. I had rebase to the gaia master before changing it. The css change seems useless, someone already changed it.
Attachment #781538 - Flags: review+ → review?(dflanagan)
Comment on attachment 781538 [details]
change css z-index and make camera go back to camera mode while usb is plugged

This is so much better! Again, I'm assuming you've tested the changes.  Thanks!
Attachment #781538 - Flags: review?(dflanagan) → review+
merged to master: https://github.com/mozilla-b2g/gaia/commit/d9a2f8ff576a253de3527b650da45040b3d0d2d2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 9

4 years ago
Hi David,

Could you merge this patch to v1.1 ?
Can we merge to v1.1???

We may need to mark this bug as leo+. If it is, John Ford will help to do that..
You need to log in before you can comment on or make changes to this bug.