Cut/Paste bookmarks in a subfolder minimizes that subfolder and focus goes to Unsorted Bookmarks

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
5 years ago
6 months ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reproducible on the latest Beta (BuildID: 20130722172257):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Reproducible on the latest Aurora (BuildID: 20130724222711):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130719 Firefox/24.0
Reproducible on the latest Nightly (BuildID: 20130724222711): 
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:25.0) Gecko/20130724 Firefox/25.0

Steps to reproduce:
1. Start Firefox.
2. Open some websites and add them to bookmark in the same folder.
3. Open the Library and go to All Bookmarks (ctrl+shift+b).
4. Go to the folder where the bookmarks were saved.
5. Select one or more bookmarks.
6. Right click and select CUT.
7. Right click again and select New Folder.
8. Enter the new created folder and paste the bookmarks selected on step 6.
9. In the new created folder repeat step 5-6-7.

Expected results: After pasting the bookmarks the focus remains on the same folder.

Actual results: After pasting the bookmarks in a second subfolder the focus moves to Unsorted Bookmarks and the folder is minimized.

Notes:
1. This issue is not a regression: it reproduces back to Firefox 7.0 (buidID: 20110922153450).
2. This issue is reproducible on Mac OS X and Ubuntu.
3. Attached screencast showing the issue.
http://www.screencast.com/t/Rlp2yFiz63Bc
I can't reproduce this in FF 57, I suspect it got fixed sometime in the last four years.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.