Closed Bug 897930 Opened 6 years ago Closed 6 years ago

Unhide hidden preference for disabling green download flash animation added in bug #861613

Categories

(Firefox :: Downloads Panel, enhancement)

24 Branch
enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 25

People

(Reporter: Virtual, Assigned: xidorn)

References

Details

(Keywords: nightly-community, Whiteboard: [good-first-bug][mentor=mak][lang=js])

Attachments

(1 file, 1 obsolete file)

There is no logical base to hide any preferences in about:config from advanced users as only advanced users use about:config.
The only users who were added to bug #861613 CC list know about his feature.
There is no information on this preference even on http://dxr.mozilla.org/
So please don't hide any preferences as it's only pains users to waste time for searching web and ask questions on support forums.
Adding "regression" to keywords as now you can't disable animation you didn't have before
Blocks: 861613
Keywords: regression
Summary: Unhide hidden preference for disabling green download flash animation → Unhide hidden preference for disabling green download flash animation added in bug #861613
When bug 861613 first landed the first thing I did was ask around, and read the patch to uncover the 'hidden' pref. 


I totally agree, the pref should be un-hidden. 

Setting to NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
no, it doesn't satisfy our regression definition, the animations are intended by design. Still a valid enh request though.
We don't have resources to work on this at the moment, but will gladly accept patches, should be as easy as adding the pref and a brief comment to http://mxr.mozilla.org/mozilla-central/source/browser/app/profile/firefox.js close to the other browser.download. prefs
Severity: major → enhancement
Keywords: regression
Whiteboard: [good-first-bug][mentor=mak][lang=js]
Target Milestone: Firefox 24 → ---
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → quanxunzhen
Status: NEW → ASSIGNED
Attachment #780971 - Flags: review?(mak77)
No longer blocks: 861613
Depends on: 861613
Version: 24 Branch → Trunk
Comment on attachment 780971 [details] [diff] [review]
patch

Review of attachment 780971 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/profile/firefox.js
@@ +332,5 @@
>  
>  // This allows disabling the Downloads Panel in favor of the old interface.
>  pref("browser.download.useToolkitUI", false);
>  
> +// This allows disabling visual notifications of Downloads Indicator

// This allows disabling the animated notifications shown by
// the Downloads Indicator when a download starts or completes.
Attachment #780971 - Flags: review?(mak77) → review+
(In reply to Marco Bonardo [:mak] from comment #5)
> Comment on attachment 780971 [details] [diff] [review]
> patch
> 
> Review of attachment 780971 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/app/profile/firefox.js
> @@ +332,5 @@
> >  
> >  // This allows disabling the Downloads Panel in favor of the old interface.
> >  pref("browser.download.useToolkitUI", false);
> >  
> > +// This allows disabling visual notifications of Downloads Indicator
> 
> // This allows disabling the animated notifications shown by
> // the Downloads Indicator when a download starts or completes.

What should I do? Should I submit a new patch with your clearer comment or just mark this bug "checkin-needed"?
(In reply to Xidorn Quan from comment #6)
> What should I do? Should I submit a new patch with your clearer comment or
> just mark this bug "checkin-needed"?

you should submit a new patch with the changed comment, the r=mak in the commit message, and then mark checkin-needed
Attached patch patchSplinter Review
Attachment #780971 - Attachment is obsolete: true
Keywords: checkin-needed
If I can I would like to request pushing this patch also for Firefox 24, so it will be easier to disable this download animation landed bug #861613.
Thanks!
sorry, but it doesn't satisfy our uplift requirements.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.