[Cost Control] FTU does not allow the user to select the plantype

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: salva, Assigned: salva)

Tracking

({regression})

unspecified
x86_64
Linux
regression

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: QARegressExclude)

Attachments

(1 attachment)

STR

0. Insert a VIVO, Colombia or Peru SIM
1. Make a reset-gaia
2. Open Usage application
3. Press next in FTU
4. Try to select the plantype

Expected:
The plantype is selected and you can progress through the wizard.

Actual:
The plantype is no selected preventing the user to complete the FTU and using the application.
Regression caused by bug 881727

This is only reproducing in v1-train
Summary: [Cost Control] FTE does not allow the user to select the plantype → [Cost Control] FTU does not allow the user to select the plantype
It seems the patch for v1-train [1] of bug 881727 introduced additional changes (in lines 96 and 102) compared with the patch for master [2]. These changes were not only unnecessary but wrong.

[1] https://github.com/mozilla-b2g/gaia/commit/06d56e0efd1cb3bbed37fef6ee45233b86b3ae3b#diff-13
[2] https://github.com/mozilla-b2g/gaia/commit/6e4ff7535ecad23252fc8360bdc92d27be1c2ee0#diff-14
Created attachment 781012 [details]
Fixing FTE, only for v1-train

This patches fixes the problem described in comment 2 by removing the changes.
Attachment #781012 - Flags: review?(francisco.jordano)
leo+ regression issue
blocking-b2g: leo? → leo+

Updated

5 years ago
Blocks: 881727
Comment on attachment 781012 [details]
Fixing FTE, only for v1-train

Simple fix, non risky :)

Thanks Salva!
Attachment #781012 - Flags: review?(francisco.jordano) → review+
v1-train: 38336b840582fbece482f2be3b5c3f92a8eba338
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed

Updated

5 years ago
Whiteboard: QARegressExclude
You need to log in before you can comment on or make changes to this bug.