Closed Bug 898079 Opened 9 years ago Closed 7 years ago

Alt+shift access keys broken, ui.key.chromeAccess ignored

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

22 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: federicoleva, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130624104217

Steps to reproduce:

1) https://en.wikipedia.org/wiki/Special:Random
2) Press alt+shift+e


Actual results:

Nothing; or, if I press 'e' strictly *after* the other keys, the "Edit" menu of Firefox opens.

This is very disrupting for the user experience on websites; it makes several tasks nearly impossible for me on my MediaWiki wikis (they take an order of magnitude time more).


Expected results:

The "edit" (or "edit source") button, having accesskey 'e' and telling me to use alt+shift+e, should have been pressed.

Workarounds tried: I saw
http://geek.co.il/2009/08/12/why-html-access-keys-do-not-work-in-firefox-linux
http://kb.mozillazine.org/Ui.key.chromeAccess
and set ui.key.chromeAccess to 0 in order to disable access keys for the menu completely, but alt+shift+e keeps to be stolen by Firefox for its menu.

Fedora 18, KDE 4.10.5.
$ uname -a
Linux ... 3.9.9-201.fc18.x86_64 #1 SMP Fri Jul 5 16:42:02 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ firefox --version
Mozilla Firefox 22.0
See Also: → 420766
Component: Untriaged → Keyboard: Navigation
Product: Firefox → Core
Cannot reproduce with Firefox 30.0 on Fedora 20. 
alt+shift+e triggers "edit source" on https://en.wikipedia.org/wiki/Special:Random
Works for me in Firefox 37.0.1 in Linux Mint KDE 17.1.
Reporter, are you still seeing this in the latest version of Firefox in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(federicoleva)
No, I've not seen it for a while, but I don't remember whether I applied some workaround to fix it.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(federicoleva)
Resolution: --- → WORKSFORME
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.