[Buri][Homescreen]Gallery forecloses when no SD card is present

RESOLVED DUPLICATE of bug 894277

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 894277
5 years ago
5 years ago

People

(Reporter: Angela Hubenya, Unassigned)

Tracking

({regression})

Trunk
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

206.07 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 781220 [details]
logcat

Description:
When user long presses home screen and selects Gallery, application forecloses. 

Prerequisite: Take out SD card

Repro Steps:
1) Updated Buri to Build ID: 20130725070209
2) Long press homescreen to get context menu
3) Select Gallery

Actual:
Gallery app forecloses.

Expected:
"No photos or videos
Use the Camera app to get started" is displayed.

Environmental Variables-
Build ID: 20130725070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia: b1945e7eca58c9176d91998390871864f5e8eb3e
Platform Version: 18.1

Notes:
Repro frequency: 100%
Logcat doesn't tell much, although if I were to guess, this is a bug in device storage. Probably a regression too.

Dave - Any thoughts?
blocking-b2g: --- → leo?
Component: Gaia::Homescreen → DOM: Device Interfaces
Keywords: regression
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Updated

5 years ago
Flags: needinfo?(dhylands)
Haven't been able to reproduce this on two different Leo devices, using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/142cb317a178
Gaia   b1945e7eca58c9176d91998390871864f5e8eb3e
BuildID 20130725070209
Version 18.0
I'll hold off nominating then until we can reproduce elsewhere then.
blocking-b2g: leo? → ---
It looks like this was reported on a Buri device, which only has sdcard storage.

Leo has an always available internal storage area, so it might behave differently.

I tried on my unagi running master and also 1.1 and in both cases I got the "No memory card" message displayed.
Flags: needinfo?(dhylands)
(Reporter)

Comment 5

5 years ago
Per comment 25 in bug https://bugzilla.mozilla.org/show_bug.cgi?id=894835#c25 
This issue should get resolved once bug 894277 is fixed.
(Reporter)

Updated

5 years ago
Depends on: 894277
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 894277
You need to log in before you can comment on or make changes to this bug.