Closed Bug 898187 Opened 8 years ago Closed 8 years ago

Projects that contain videos that are taken down fail to load

Categories

(Webmaker Graveyard :: Popcorn Maker, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: brett, Assigned: thecount)

Details

(Whiteboard: popbetter)

Attachments

(1 file)

This project:
http://dunja.makes.org/popcorn/181g

Contains a video that has been taken down due to copyright concerns (add /remix at the end of the url and examine the clips used in the timeline)

While we can't do anything about this, we should still be able to load the video without those clips.

Does youtube's API give information like this?  Could we provide some sort of notification to the user?
Turns out we can detect this via error events.
Attachment #781391 - Flags: review?(schranz.m)
Attachment #781391 - Flags: review?(schranz.m) → review+
Staged: https://github.com/mozilla/popcorn.webmaker.org/commit/0c08cf32f9e27b3032fdee5b23952a732f6c917d

Needs verification.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(scott)
Resolution: --- → FIXED
I'm getting better results with this problem reproduced in a reduced project.

In a more complex project it comes back. bug 893777 should fix that, so I'll wait until bug 893777 lands before I mark this as verified.
Oops, the above comment was meant for bug 897327.

This one is in fact verified.
Flags: needinfo?(scott)
Status: RESOLVED → VERIFIED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.