Status

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: gasolin, Assigned: gasolin)

Tracking

unspecified
Other
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:hd+, b2g18 fixed, b2g-v1.1hd fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

Assignee

Description

6 years ago
in HD device, canvas not scaled, y-axis font is blur

expect result:

sharp canvas and clear fonts
Assignee

Updated

6 years ago
blocking-b2g: --- → hd?
Can anyone in Taipei work on this?
blocking-b2g: hd? → hd+
Flags: needinfo?(ehung)
Assignee

Comment 2

6 years ago
I'd do the followup work
Assignee: nobody → gasolin
Flags: needinfo?(ehung)
Assignee

Updated

6 years ago
Blocks: 898262
Assignee

Comment 3

6 years ago
WIP: grid section ok, but fonts are still small
Assignee

Comment 4

6 years ago
Assignee

Comment 5

6 years ago
Posted file pull_request.html
fixed canvas blur issue and make limit line looks similar to origin res.

But number font is still small (even after set font size * pixelRatio) ... need some help on that
Attachment #784279 - Flags: review?(salva)
Assignee

Comment 6

6 years ago
Posted image device-2013-08-01-163904.png (obsolete) —
current PR looking
Assignee

Comment 7

6 years ago
root cause of canvas font Size issue is `context.fontSize` does not exist. Replace to `context.font` works. squashed PR.
Attachment #784280 - Attachment is obsolete: true
Comment on attachment 784279 [details]
pull_request.html

All seems ok to me but please, read the comment on GitHub and wrap the conversion into a function. Thank you very much.
Attachment #784279 - Flags: review?(salva) → review+
Assignee

Comment 9

6 years ago
merged to gaia-master
https://github.com/mozilla-b2g/gaia/commit/da62699b5aeef0654bcfa2189946db0f9505fd13

(use `toDevicePixels` function to perform this conversion instead of inlining it)
thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hey guys!

You've landed bug 898262 but that bug introduces changes depending on this one which is not landed on HD while it was flagged as HD+.

Can you land this in order to fix the HD branch, please?
Flags: needinfo?(gasolin)

Comment 12

6 years ago
[2013/10/21 Helix Testing]
Gaia:     c829a2042594b6c3a4899ee27979799a0f301534
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f7c657f6d019
BuildID   20131015042201
Version   18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.