[Helix] Pictures shot in landscape mode cannot be displayed vertically in portrait mode for user to view it with same direction in Gallery.

RESOLVED DUPLICATE of bug 898395

Status

Firefox OS
Gaia::Gallery
RESOLVED DUPLICATE of bug 898395
4 years ago
4 years ago

People

(Reporter: Enpei, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 781524 [details]
20130726_143111.jpg

Pictures taken in landscape mode should still be able to be displayed in correct direction(vertically) in portrait mode for user to watch it even with smaller size. If users want to see it in full screen size, they can rotate device to landscape mode. 

* Build Number                 
Gaia:     f2bc4a004f592cd6dce4edda2b0533f4fd4f91f2
  B-D     2013-07-25 18:32:32
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/2bb08f2878da
BuildID   20130725070202
Version   18.1

* Reproduce Steps
1. Take a picture in landscape mode.
2. View it in portrait mode in Gallery.

* Expected Result
Picture is in displayed vertically that user can still view the correct direction picture. 

* Actual Result
Picture still in landscape mode size and for user who hand the phone in portrait mode, things are not in the correct direction for user.
(Reporter)

Updated

4 years ago
Summary: [Helix] Picture taken in landscape mode cannot be displayed vertically in portrait mode when viewing it in Gallery. → [Helix] Pictures shot in landscape mode cannot be displayed vertically in portrait mode for user to view it with same direction in Gallery.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → hd?
Likely due to bug 898395.
blocking-b2g: hd? → hd+
Created attachment 784892 [details]
landscape-picture-in-portrait-gallery.png

Hi all, 

This bug is not in Gallery. It origins from Camera app. If camera supplies the correct orientation while taking picture, Gallery app shows in correct way. This attachment is captured in helix with landscape picture which is also took by the same helix.
Dup based on comment 1 and comment 2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898395
You need to log in before you can comment on or make changes to this bug.