Closed Bug 89832 Opened 22 years ago Closed 21 years ago

skin's !important attribute cannot be overridden in userChrome

Categories

(Core Graveyard :: Skinability, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 43220

People

(Reporter: acapnotic, Assigned: bugs)

Details

When using Alfred's "littlemozilla" theme, I discovered that
I could not increase the font size in the urlbar (or any other
text-entry widgets) through userContent.css.  It seems that
littlemozilla set this in global/textbox.css:

html|*.textbox-input, html|*.textbox-textarea {
    /* ... */
    font-size: 8pt !important;
}

and while I can override littlemozilla's font settings where
they're not marked !important (e.g. menus), I can't override
this one in userChrome.css, with e.g.:

text#urlbar { font-size: 24pt !important;
              font-family: sans-serif !important; }

html|*.textbox-input, html|*.textbox-textarea {
        font-size           : 24pt !important;
}

...the font remains the inscruitable 8pt.

1: littlemozilla:
http://x.themes.org/viewresources.phtml?query=simplesearch&type=chrome&namedes=littlemozilla&odby=name&sc=asc&displaytype=normal&numthemes=10
ccing style people...
Status: UNCONFIRMED → NEW
Ever confirmed: true
The question here is what is the cascade for skins/chromes?
see bug 43220 - might be illuminating.

*** This bug has been marked as a duplicate of 43220 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.