Closed Bug 898325 Opened 7 years ago Closed 6 years ago

[META] Migrate bookmarks to a Data Store in order to share them among homescreens

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S5 (11apr)

People

(Reporter: vingtetun, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Data Store is closed. It would be nice to move the bookmarks database out of the Homescreen and expose it as a data store in the system app in order to not loose the database on a homescreen switch.

I also wonder if this should go into the platform at some point. That would make it easier to sync across devices. This is an other story but such a shift will move us closer to that.
Hi!

As DataStore API is really close to landing I started working on this. Noticed that the System app couldn't handle web activities (It can listen to them, but can't handle them). I can dig into why that is, but :crdlc suggested I make a separate Bookmarks app with role=system that listen on save-bookmark activity and exposes the Data Store. Agree?
(In reply to Olav Nymoen [:olav] from comment #1)
> Hi!
> 
> As DataStore API is really close to landing I started working on this.
> Noticed that the System app couldn't handle web activities (It can listen to
> them, but can't handle them). I can dig into why that is, but :crdlc
> suggested I make a separate Bookmarks app with role=system that listen on
> save-bookmark activity and exposes the Data Store. Agree?

I think it's nice if the System app does not handle that directly for now. What about using the Settings apps to do that?

The panel has already the Settings style and I can also imagine the Settings app reusing this panel to manually add new bookmarks or even to edit them if you want to change the url or the title later.
Marking as duplicate of the new Bookmark Migration metatask, since it's going to be a fairly involved process requiring multiple bugs now.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937349
That does not sounds a duplicate of bug 937349 as this one is more related to the homescreen.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → crdlc
Status: REOPENED → ASSIGNED
Summary: Prototype moving Bookmarks to a Data Store → [META] Migrate bookmarks to a Data Store in order to share them among homescreens
Depends on: 988172
Depends on: 988174
Depends on: 988177
Depends on: 990542
Whiteboard: [systemsfe]
Depends on: 994668
All dependencies were closed
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S5 (11apr)
You need to log in before you can comment on or make changes to this bug.