after onChange function, option in "select" doesn't change

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: kota, Assigned: jst)

Tracking

({testcase})

Trunk
x86
FreeBSD
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I choose option in select list and Javascript put .* in the next text field.
Mozilla show that it chooses option. But then I press submit button, it send the
first option from select (not my choise). 
Mozilla/5.0 (X11; U; FreeBSD 4.3-STABLE i386 Mozilla/5.0 (X11; U; FreeBSD
4.3-STABLE i386; en-US; rv:0.9.1) Gecko/20010611
Under Netscape & IE this html work fine, but under Mozilla not...
html is small, I send the example:

<html>
<head>
</head>

<script language="JavaScript">

<!--

function FillNext(ptr) {
    var length, i;
    var msg = "";
    
    length = document.forms[0].elements.length;
    for (i=0; i<length; i++) {
        msg += i + "\t" + document.forms[0].elements[i].name + "\n";
        if (document.forms[0].elements[i].name == ptr.name) {
            //alert(ptr.selectedIndex);
            break;
        }
    }
    if (document.forms[0].elements[i+1].value == "" ||
        document.forms[0].elements[i+1].value == "%" ||
        document.forms[0].elements[i+1].value == ".*") {
        switch (ptr.selectedIndex) {
            case 6:
                document.forms[0].elements[i+1].value = ".*";
                break;
        }
        
    }
    
    //alert(ptr.name + "\n" + msg);
    return true;
}

//-->

</script>

<body bgcolor="#E4E4E4">
<center>
<form class="input">
<input type=hidden name="nRet" value="-1"><table border=0>
<tr>
        <td class="tdmenu"><a href="/">[???????]</a>&nbsp;</td>
        <td class="tdmenu"><a
href="javascript:history.go(-1)">[?????]</a>&nbsp;</td>
</tr>
</table>
</center>
<center>
<table border=0 cellspacing=1 cellpadding=0 width=95%>
<tr align=center>
        <td class="tdtxt">&nbsp;</td>
        <td class="tdtxt"><select name="search__choice[0][fld]">
        <option value="statname__statname">ch1
        <option value="ppp__login">ch2
        <option value="POP3__login">ch3
        <option value="client__num">ch4
        <option value="client__name">ch5
        <option value="subacct__id">ch6
        <option value="client__tel">ch7
        <option value="client__fio">ch8
        <option value="client__rschet">ch9
        <option value="client__okpo">ch10
        <option value="subacct__fio_cl">ch12
        <option value="dns_soa__zona">ch13
        <option value="mforward__src_domain">ch14
        <option value="mforward__dst_domain">ch15
        <option value="ll__name">ch16
</select>
</td>
        <td class="tdtxt"><select name="search__choice[0][equation]"
OnChange="FillNext(this)">
        <option value="="> = 
        <option value=">">&gt;
        <option value="<">&lt;
        <option value=">=">&gt;=
        <option value="<=">&lt;=
        <option value="!=">not eq
        <option value=" rlike ">RLIKE THAT
</select>
</td>
        <td class="tdtxt" align=left><input type=text
name="search__choice[0][val]" value=""></td>
</tr>
<tr>
<th class="tdtxt"><input type=submit name=add value="  +  "></th>
<th class="tdtxt"><input type=submit name=act value="Search"></th>
<th class="tdtxt"><input type=submit name=del value="  -  "></th>
<th class="tdtxt"><font size=1><b>?????? ??</b>- <a
href="/Help/regex.html">POSIX reg expression</a></font></th>
</tr>
</form>
</table>
</center>
</body>
</html>
Over to DOM 0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 2

18 years ago
Created attachment 44207 [details]
The testcase provided by the user

Updated

18 years ago
Keywords: testcase
Andrey, I can't reproduce this bug with linux build 2001-09-07-12.  Are you
still seeing it with recent builds?  Is this BSD-specific (that seems fairly
unlikely).

Comment 4

17 years ago
I see this working on 0.9.4 Linux.  Andrey, could you please confirm?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.