segfault in inflate_fast in libmozz.so on startup

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: BackEnd
--
critical
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Paul McGarry, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({crash, smoketest})

Trunk
x86
Linux
crash, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
BuildID:    2001070721

Trying to start mozilla profile results in a segfault.
Without a profile mozilla will start up, do the profile migration and continue
running. But if you shut it down and start it up again it will then segfault.

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla


Actual Results:  segfault:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 301]
0x40821635 in inflate_fast () from /home/paulm/mozilla/libmozz.so
(gdb) bt
#0  0x40821635 in inflate_fast () from /home/paulm/mozilla/libmozz.so
#1  0x40820c16 in inflate_codes () from /home/paulm/mozilla/libmozz.so
#2  0x4081fd10 in inflate_blocks () from /home/paulm/mozilla/libmozz.so
#3  0x4081ede1 in inflate () from /home/paulm/mozilla/libmozz.so
#4  0x40c70538 in NSGetModule () from /home/paulm/mozilla/components/libjar50.so
#5  0x40c6f84a in NSGetModule () from /home/paulm/mozilla/components/libjar50.so
#6  0x40c6f44e in NSGetModule () from /home/paulm/mozilla/components/libjar50.so
#7  0x40c715ad in NSGetModule () from /home/paulm/mozilla/components/libjar50.so
#8  0x407f0876 in NSGetModule () from /home/paulm/mozilla/components/libnecko.so
#9  0x407b3672 in NSGetModule () from /home/paulm/mozilla/components/libnecko.so
#10 0x407b3513 in NSGetModule () from /home/paulm/mozilla/components/libnecko.so
#11 0x40135866 in nsThreadPoolRunnable::Run () from /home/paulm/mozilla/libxpcom.so
#12 0x401345fa in nsThread::Main () from /home/paulm/mozilla/libxpcom.so
#13 0x401bd6ee in PR_Select () from /home/paulm/mozilla/libnspr4.so
#14 0x401d9e3e in pthread_start_thread () from /lib/libpthread.so.0


Expected Results:  No segfault
Severity: critical → blocker
Keywords: smoketest

Comment 1

17 years ago
Marking NEW.
Severity: blocker → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
prof mgr? grace, let me know if this crash is due to migration or not...
Assignee: pchen → ccarlen
Component: XP Apps → Profile Manager BackEnd
QA Contact: sairuh → gbush
(Reporter)

Comment 3

17 years ago
I saw this problem consistantly around the time I reported it, stopped using moz
for a while because of it and now I don't see this problem any more.
Don't keep the bug open on my account.

Comment 4

17 years ago
resolving per reporter's comment
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.