[Camera][Helix][V1.1.0 HD] The camera app still works after connecting the USB

VERIFIED FIXED

Status

Firefox OS
Gaia::Camera
--
major
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
* Description:
  This case happened on Helix V1.1.0 HD build.
  Enabling the USB mass storage mode.
  Launching the camera app then connect to PC via USB.
  The camera app still works and can take a picture.

* Reproduction steps:
  1. Enabling the USB mass storage mode.
  2. Launch the camera app of Helix device
  3. Connect to PC via USB

* Expected result:
  The camera app should be stopped

* Actual result:
  The camera app still work and can take a picture.

* Reproduction build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-07-25-07-02-02)
  + Mercurial-Information
    - Gecko revision="2bb08f2878da"
  + Git-information
    - Gaia revision="f2bc4a004f592cd6dce4edda2b0533f4fd4f91f2"
No longer reproduceable. Camera app displays blocking overlay as expected.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

4 years ago
Verified it.
I cannot reproduce it on V2.0 branch, but still can reproduce it on V1.1.0 hd branch.

* Build information:(V2.0)
 - Gaia      f0463704888881b8ed1619e8d4b0d851b0e0311b
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/1d0496e30feb
 - BuildID   20140422040203
 - Version   31.0a1

* Result:
 - Cannot reproduce on V2.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.