crash on delete of a particular visited bookmark

VERIFIED DUPLICATE of bug 85617

Status

--
critical
VERIFIED DUPLICATE of bug 85617
18 years ago
14 years ago

People

(Reporter: sjburges, Assigned: bugs)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010628
BuildID:    2001062814

Attempting to remove a particular bookmark after viewing it results in a hang of
the software.

Reproducible: Always
Steps to Reproduce:
1.Go to Manage Bookmarks
2.Double click on bookmark for http://members.tripod.com/~ko5tik/graphics/
(title is "Konstantin Priblouda Graphix Page", with "ix Page" represented as ...
in the bookmark manager)
3.Cose the window that is opened
4. Delete the entry

Actual Results:  Mozilla becomes completely non-responsive, screen updates cease.

Expected Results:  Delete the bookmark

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
Need a stacktrace and/or talkback id for this to be useful.
Keywords: stackneeded
(Reporter)

Comment 2

18 years ago
Created attachment 41705 [details]
Bookmark file that will hang mozilla
(Reporter)

Comment 3

18 years ago
Actually viewing is not necessary.  I just reinstalled, converted profile,
started deleting.  When I got to this URL, it hung immediately afterwards.  This
is the stack trace I got from hitting ctrl-c after it had hung.  Doesn't look
terribly useful to me; if you can suggest a better method of getting a
stacktrace I'm open to that too...

Seth

Program received signal SIGINT, Interrupt.
[Switching to Thread 2051 (LWP 8440)]
0x404a6d0e in sigsuspend () from /lib/libc.so.6
(gdb) bt
#0  0x404a6d0e in sigsuspend () from /lib/libc.so.6
#1  0x401de6eb in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
#2  0x401db0c2 in pthread_cond_wait () from /lib/libpthread.so.0
#3  0x401ba3fe in PR_WaitCondVar () from ./libnspr4.so
#4  0x407793b3 in NSGetModule () from /home/seth/mozilla/components/libnecko.so
#5  0x4077900b in NSGetModule () from /home/seth/mozilla/components/libnecko.so
#6  0x401355fa in nsThread::Main () from ./libxpcom.so
#7  0x401be6ee in PR_Select () from ./libnspr4.so
#8  0x401dbfc5 in pthread_start_thread () from /lib/libpthread.so.0
#9  0x401dc00d in pthread_start_thread_event () from /lib/libpthread.so.0
(gdb) 

Comment 4

18 years ago
Dupe of 85617 exact same stacktrace.

*** This bug has been marked as a duplicate of 85617 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.