Work - Top site thumbnails don't display if startup pref 'open tabs from last time' is set

RESOLVED FIXED in Firefox 25

Status

P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jimm, Assigned: mbrubeck)

Tracking

Trunk
Firefox 25
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) in options, set Startup pref to "tabs from last time"
2) open a web page
3) close
4) reopen

result: web page from step 2 should be loaded

5) open tab bar and close the tab

result: start page loads without top site thumbnails

Updated

5 years ago
Summary: Top site thumbnails don't display if startup pref 'open tabs from last time' is set → Defect - Top site thumbnails don't display if startup pref 'open tabs from last time' is set
Whiteboard: feature=defect c=tbd u=tbd p=0
Confirmed, there must be some init step that isn't taking place if the browser launches displaying another page.

Comment 2

5 years ago
We either need to fix this or drop the option to start up with tabs from last time. I'm OK with either one.
Priority: -- → P1

Updated

5 years ago
Blocks: 831920
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=firefox_start u=tbd p=0

Updated

5 years ago
No longer blocks: 859003
Whiteboard: feature=defect c=firefox_start u=tbd p=0 → feature=defect

Updated

5 years ago
Blocks: 859003
Whiteboard: feature=defect → feature=defect c=firefox_start u=tbd p=0

Updated

5 years ago
No longer blocks: 859003
Summary: Defect - Top site thumbnails don't display if startup pref 'open tabs from last time' is set → Work - Top site thumbnails don't display if startup pref 'open tabs from last time' is set
Whiteboard: feature=defect c=firefox_start u=tbd p=0 → feature=work
(Assignee)

Updated

5 years ago
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Is this also an issue when recovering from a crash? If that's the case then I imagine that we'll want to fix this regardless of whether we keep the "tabs from last time" options
(Assignee)

Comment 4

5 years ago
Created attachment 782628 [details] [diff] [review]
patch

This was our usual problem with accessing XBL properties before the item was bound (in this case because the Start page was not displayed at startup), with the usual solution.

I'll see if I can come up with a useful test for this bug too.
Attachment #782628 - Flags: review?(ally)
Comment on attachment 782628 [details] [diff] [review]
patch

Review of attachment 782628 [details] [diff] [review]:
-----------------------------------------------------------------

and this is the usual r+ and routine sidelong glare at xbl for this issue.
Attachment #782628 - Flags: review?(ally) → review+
https://hg.mozilla.org/mozilla-central/rev/fed05531f9e3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.